<!doctype html>
<html lang="en-US">
<head>
<meta charset="UTF-8" />
<meta name="viewport" content="width=device-width, initial-scale=1" />

<link rel="preconnect" href="https://config.playwire.com" crossorigin />
<link rel="preconnect" href="https://cdn.intergi.com" crossorigin />
<link rel="preconnect" href="https://cdn.intergient.com" crossorigin />
<link rel="preconnect" href="https://securepubads.g.doubleclick.net" crossorigin />
<link rel="preconnect" href="https://cdn.playwire.com" crossorigin />
<link rel="preconnect" href="https://cdn.video.playwire.com" crossorigin />
<link rel="preconnect" href="https://z.moatads.com" crossorigin />
<script src="https://btloader.com/tag?o=5150306120761344&upapi=true" async></script>

<link rel="preconnect" href="https://ws-na.amazon-adsystem.com" crossorigin />

<link rel="preload" href="https://fonts.gstatic.com/s/karla/v15/qkBbXvYC6trAT7RVLtyU5rZP.woff2" as="font" type="font/woff2" crossorigin>
<link rel="preload" href="https://fonts.gstatic.com/s/poppins/v15/pxiByp8kv8JHgFVrLCz7Z1xlFd2JQEk.woff2" as="font" type="font/woff2" crossorigin>
<link rel="profile" href="https://gmpg.org/xfn/11" />
<link rel="shortcut icon" type="image/png" href="https://www.giantfreakinrobot.com/wp-content/themes/face3-gfr/assets/images/gfr-favicon.png" />
<meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />

<title>Guardians Of The Galaxy 3 Won’t See A Crucial Actor Return</title>
<meta name="description" content="James Gunn says a crucial member of the Guardians franchise will not be returning for Guardians of the Galaxy 3! Find out why!" />
<link rel="canonical" href="https://www.giantfreakinrobot.com/ent/guardians-of-the-galaxy-3-yondu.html" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Guardians Of The Galaxy 3 Won’t See A Crucial Actor Return" />
<meta property="og:description" content="James Gunn says a crucial member of the Guardians franchise will not be returning for Guardians of the Galaxy 3! Find out why!" />
<meta property="og:url" content="https://www.giantfreakinrobot.com/ent/guardians-of-the-galaxy-3-yondu.html" />
<meta property="og:site_name" content="GIANT FREAKIN ROBOT" />
<meta property="article:publisher" content="https://www.facebook.com/giantfreakinrobot" />
<meta property="article:published_time" content="2021-11-03T22:56:24+00:00" />
<meta property="og:image" content="https://www.giantfreakinrobot.com/wp-content/uploads/2019/12/guardians-1-e1635979528451.jpg" />
<meta property="og:image:width" content="837" />
<meta property="og:image:height" content="470" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:creator" content="@GFRobot" />
<meta name="twitter:site" content="@GFRobot" />
<meta name="twitter:label1" content="Written by" />
<meta name="twitter:data1" content="Dylan Balde" />
<meta name="twitter:label2" content="Est. reading time" />
<meta name="twitter:data2" content="4 minutes" />
<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://www.giantfreakinrobot.com/#organization","name":"GIANT FREAKIN ROBOT","url":"https://www.giantfreakinrobot.com/","sameAs":["https://www.facebook.com/giantfreakinrobot","https://www.instagram.com/gfrobo/","https://www.linkedin.com/company/gfrobot/","https://www.youtube.com/channel/UCR4if3TFE8RvtFf-HFlMu9w","https://www.pinterest.com/gfrobot/","https://twitter.com/GFRobot"],"logo":{"@type":"ImageObject","@id":"https://www.giantfreakinrobot.com/#logo","inLanguage":"en-US","url":"https://www.giantfreakinrobot.com/wp-content/uploads/2021/07/GFRlogo-scaled.jpg","contentUrl":"https://www.giantfreakinrobot.com/wp-content/uploads/2021/07/GFRlogo-scaled.jpg","width":2560,"height":1499,"caption":"GIANT FREAKIN ROBOT"},"image":{"@id":"https://www.giantfreakinrobot.com/#logo"}},{"@type":"WebSite","@id":"https://www.giantfreakinrobot.com/#website","url":"https://www.giantfreakinrobot.com/","name":"GIANT FREAKIN ROBOT","description":"Stomping into the future of everything.","publisher":{"@id":"https://www.giantfreakinrobot.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"https://www.giantfreakinrobot.com/?s={search_term_string}"},"query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://www.giantfreakinrobot.com/ent/guardians-of-the-galaxy-3-yondu.html#primaryimage","inLanguage":"en-US","url":"https://www.giantfreakinrobot.com/wp-content/uploads/2019/12/guardians-1-e1635979528451.jpg","contentUrl":"https://www.giantfreakinrobot.com/wp-content/uploads/2019/12/guardians-1-e1635979528451.jpg","width":837,"height":470,"caption":"Guardians Of The Galaxy Vol. 2..L to R: Yondu (Michael Rooker), Nebula (Karen Gillan), Star-Lord/Peter Quill (Chris Pratt), Gamora (Zoe Saldana), Mantis (Pom Klementieff), Drax (Dave Bautista), Rocket (Voiced by Bradley Cooper) and Groot (Voiced by Vin Diesel)..Ph: Film Frame..\u00a9Marvel Studios 2017"},{"@type":"WebPage","@id":"https://www.giantfreakinrobot.com/ent/guardians-of-the-galaxy-3-yondu.html#webpage","url":"https://www.giantfreakinrobot.com/ent/guardians-of-the-galaxy-3-yondu.html","name":"Guardians Of The Galaxy 3 Won\u2019t See A Crucial Actor Return","isPartOf":{"@id":"https://www.giantfreakinrobot.com/#website"},"primaryImageOfPage":{"@id":"https://www.giantfreakinrobot.com/ent/guardians-of-the-galaxy-3-yondu.html#primaryimage"},"datePublished":"2021-11-03T22:56:24+00:00","dateModified":"2021-11-03T22:56:24+00:00","description":"James Gunn says a crucial member of the Guardians franchise will not be returning for Guardians of the Galaxy 3! Find out why!","breadcrumb":{"@id":"https://www.giantfreakinrobot.com/ent/guardians-of-the-galaxy-3-yondu.html#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://www.giantfreakinrobot.com/ent/guardians-of-the-galaxy-3-yondu.html"]}]},{"@type":"BreadcrumbList","@id":"https://www.giantfreakinrobot.com/ent/guardians-of-the-galaxy-3-yondu.html#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"GFR Home","item":"https://www.giantfreakinrobot.com/"},{"@type":"ListItem","position":2,"name":"Guardians Of The Galaxy 3 Won\u2019t See A Crucial Actor Return"}]},{"@type":"Article","@id":"https://www.giantfreakinrobot.com/ent/guardians-of-the-galaxy-3-yondu.html#article","isPartOf":{"@id":"https://www.giantfreakinrobot.com/ent/guardians-of-the-galaxy-3-yondu.html#webpage"},"author":{"@id":"https://www.giantfreakinrobot.com/#/schema/person/8fb3cad603eaddae009885760faf1055"},"headline":"Guardians Of The Galaxy 3 Won\u2019t See A Crucial Actor Return","datePublished":"2021-11-03T22:56:24+00:00","dateModified":"2021-11-03T22:56:24+00:00","mainEntityOfPage":{"@id":"https://www.giantfreakinrobot.com/ent/guardians-of-the-galaxy-3-yondu.html#webpage"},"wordCount":716,"publisher":{"@id":"https://www.giantfreakinrobot.com/#organization"},"image":{"@id":"https://www.giantfreakinrobot.com/ent/guardians-of-the-galaxy-3-yondu.html#primaryimage"},"thumbnailUrl":"https://www.giantfreakinrobot.com/wp-content/uploads/2019/12/guardians-1-e1635979528451.jpg","articleSection":["Movies &amp; TV"],"inLanguage":"en-US"},{"@type":"Person","@id":"https://www.giantfreakinrobot.com/#/schema/person/8fb3cad603eaddae009885760faf1055","name":"Dylan Balde","image":{"@type":"ImageObject","@id":"https://www.giantfreakinrobot.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/80c5cd386b0908ab570c8c0bca6fc917?s=96&d=mm&r=pg","contentUrl":"https://secure.gravatar.com/avatar/80c5cd386b0908ab570c8c0bca6fc917?s=96&d=mm&r=pg","caption":"Dylan Balde"},"url":"https://www.giantfreakinrobot.com/author/dylanbalde"}]}</script>

<link rel='dns-prefetch' href='//stackpath.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//www.giantfreakinrobot.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//pagead2.googlesyndication.com' />
<link rel="alternate" type="application/rss+xml" title="GIANT FREAKIN ROBOT &raquo; Feed" href="https://www.giantfreakinrobot.com/feed" />
<link rel="alternate" type="application/rss+xml" title="GIANT FREAKIN ROBOT &raquo; Comments Feed" href="https://www.giantfreakinrobot.com/comments/feed" />
<link rel='stylesheet' id='wp-block-library-css' href='https://www.giantfreakinrobot.com/wp-includes/css/dist/block-library/style.min.css?ver=787efb762acdfbea5a8cbc3af797c21d' media='all' />
<style id='wp-block-library-theme-inline-css'>
#start-resizable-editor-section{display:none}.wp-block-audio figcaption{color:#555;font-size:13px;text-align:center}.is-dark-theme .wp-block-audio figcaption{color:hsla(0,0%,100%,.65)}.wp-block-code{font-family:Menlo,Consolas,monaco,monospace;color:#1e1e1e;padding:.8em 1em;border:1px solid #ddd;border-radius:4px}.wp-block-embed figcaption{color:#555;font-size:13px;text-align:center}.is-dark-theme .wp-block-embed figcaption{color:hsla(0,0%,100%,.65)}.blocks-gallery-caption{color:#555;font-size:13px;text-align:center}.is-dark-theme .blocks-gallery-caption{color:hsla(0,0%,100%,.65)}.wp-block-image figcaption{color:#555;font-size:13px;text-align:center}.is-dark-theme .wp-block-image figcaption{color:hsla(0,0%,100%,.65)}.wp-block-pullquote{border-top:4px solid;border-bottom:4px solid;margin-bottom:1.75em;color:currentColor}.wp-block-pullquote__citation,.wp-block-pullquote cite,.wp-block-pullquote footer{color:currentColor;text-transform:uppercase;font-size:.8125em;font-style:normal}.wp-block-quote{border-left:.25em solid;margin:0 0 1.75em;padding-left:1em}.wp-block-quote cite,.wp-block-quote footer{color:currentColor;font-size:.8125em;position:relative;font-style:normal}.wp-block-quote.has-text-align-right{border-left:none;border-right:.25em solid;padding-left:0;padding-right:1em}.wp-block-quote.has-text-align-center{border:none;padding-left:0}.wp-block-quote.is-large,.wp-block-quote.is-style-large{border:none}.wp-block-search .wp-block-search__label{font-weight:700}.wp-block-group.has-background{padding:1.25em 2.375em;margin-top:0;margin-bottom:0}.wp-block-separator{border:none;border-bottom:2px solid;margin-left:auto;margin-right:auto;opacity:.4}.wp-block-separator:not(.is-style-wide):not(.is-style-dots){width:100px}.wp-block-separator.has-background:not(.is-style-dots){border-bottom:none;height:1px}.wp-block-separator.has-background:not(.is-style-wide):not(.is-style-dots){height:2px}.wp-block-table thead{border-bottom:3px solid}.wp-block-table tfoot{border-top:3px solid}.wp-block-table td,.wp-block-table th{padding:.5em;border:1px solid;word-break:normal}.wp-block-table figcaption{color:#555;font-size:13px;text-align:center}.is-dark-theme .wp-block-table figcaption{color:hsla(0,0%,100%,.65)}.wp-block-video figcaption{color:#555;font-size:13px;text-align:center}.is-dark-theme .wp-block-video figcaption{color:hsla(0,0%,100%,.65)}.wp-block-template-part.has-background{padding:1.25em 2.375em;margin-top:0;margin-bottom:0}#end-resizable-editor-section{display:none}
</style>
<style id="google-fonts-css" media="all">@font-face {
  font-family: 'Karla';
  font-style: italic;
  font-weight: 400;
  font-display: swap;
  src: url(/fonts.gstatic.com/s/karla/v15/qkBKXvYC6trAT7RQNNK2EG7SIwPWMNlCV3lIb7Y.ttf) format('truetype');
}
@font-face {
  font-family: 'Karla';
  font-style: normal;
  font-weight: 400;
  font-display: swap;
  src: url(/fonts.gstatic.com/s/karla/v15/qkBIXvYC6trAT55ZBi1ueQVIjQTD-JqaE0lP.ttf) format('truetype');
}
@font-face {
  font-family: 'Karla';
  font-style: normal;
  font-weight: 700;
  font-display: swap;
  src: url(/fonts.gstatic.com/s/karla/v15/qkBIXvYC6trAT55ZBi1ueQVIjQTDH52aE0lP.ttf) format('truetype');
}
@font-face {
  font-family: 'Lato';
  font-style: italic;
  font-weight: 400;
  font-display: swap;
  src: url(/fonts.gstatic.com/s/lato/v20/S6u8w4BMUTPHjxsAXC-v.ttf) format('truetype');
}
@font-face {
  font-family: 'Lato';
  font-style: normal;
  font-weight: 300;
  font-display: swap;
  src: url(/fonts.gstatic.com/s/lato/v20/S6u9w4BMUTPHh7USSwiPHA.ttf) format('truetype');
}
@font-face {
  font-family: 'Lato';
  font-style: normal;
  font-weight: 400;
  font-display: swap;
  src: url(/fonts.gstatic.com/s/lato/v20/S6uyw4BMUTPHjx4wWw.ttf) format('truetype');
}
@font-face {
  font-family: 'Lato';
  font-style: normal;
  font-weight: 700;
  font-display: swap;
  src: url(/fonts.gstatic.com/s/lato/v20/S6u9w4BMUTPHh6UVSwiPHA.ttf) format('truetype');
}
@font-face {
  font-family: 'Lato';
  font-style: normal;
  font-weight: 900;
  font-display: swap;
  src: url(/fonts.gstatic.com/s/lato/v20/S6u9w4BMUTPHh50XSwiPHA.ttf) format('truetype');
}
@font-face {
  font-family: 'Poppins';
  font-style: normal;
  font-weight: 300;
  font-display: swap;
  src: url(/fonts.gstatic.com/s/poppins/v15/pxiByp8kv8JHgFVrLDz8Z1xlEA.ttf) format('truetype');
}
@font-face {
  font-family: 'Poppins';
  font-style: normal;
  font-weight: 400;
  font-display: swap;
  src: url(/fonts.gstatic.com/s/poppins/v15/pxiEyp8kv8JHgFVrJJfedw.ttf) format('truetype');
}
@font-face {
  font-family: 'Poppins';
  font-style: normal;
  font-weight: 600;
  font-display: swap;
  src: url(/fonts.gstatic.com/s/poppins/v15/pxiByp8kv8JHgFVrLEj6Z1xlEA.ttf) format('truetype');
}
@font-face {
  font-family: 'Poppins';
  font-style: normal;
  font-weight: 700;
  font-display: swap;
  src: url(/fonts.gstatic.com/s/poppins/v15/pxiByp8kv8JHgFVrLCz7Z1xlEA.ttf) format('truetype');
}
</style>
<link rel='stylesheet' id='fontawesome-css' href='https://www.giantfreakinrobot.com/wp-content/themes/face3-gfr/node_modules/@fortawesome/fontawesome-free/css/all.min.css?ver=1.1.0' media='all' />
<link rel='stylesheet' id='twentynineteen-style-css' href='https://www.giantfreakinrobot.com/wp-content/themes/twentynineteen/style.css?ver=1.1.0' media='all' />
<link rel='stylesheet' id='face3_gfr-main-style-css' href='https://www.giantfreakinrobot.com/wp-content/themes/face3-gfr/assets/css/main.css?ver=1.1.0' media='all' />
<link rel='stylesheet' id='twentynineteen-print-style-css' href='https://www.giantfreakinrobot.com/wp-content/themes/twentynineteen/print.css?ver=1.1.0' media='print' />
<script src='https://www.giantfreakinrobot.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script>
<script src='https://www.giantfreakinrobot.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<link rel="https://api.w.org/" href="https://www.giantfreakinrobot.com/wp-json/" /><link rel="alternate" type="application/json" href="https://www.giantfreakinrobot.com/wp-json/wp/v2/posts/308445" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.giantfreakinrobot.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.giantfreakinrobot.com/wp-includes/wlwmanifest.xml" />
<link rel='shortlink' href='https://www.giantfreakinrobot.com/?p=308445' />
<link rel="alternate" type="application/json+oembed" href="https://www.giantfreakinrobot.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.giantfreakinrobot.com%2Fent%2Fguardians-of-the-galaxy-3-yondu.html" />
<link rel="alternate" type="text/xml+oembed" href="https://www.giantfreakinrobot.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.giantfreakinrobot.com%2Fent%2Fguardians-of-the-galaxy-3-yondu.html&#038;format=xml" />
<meta property="fb:pages" content="89650649583" />
<meta name="generator" content="Site Kit by Google 1.44.0" />

<meta name="google-adsense-platform-account" content="ca-host-pub-2644536267352236">
<meta name="google-adsense-platform-domain" content="sitekit.withgoogle.com">

<meta name="onesignal" content="wordpress-plugin" />
<script>

      window.OneSignal = window.OneSignal || [];

      OneSignal.push( function() {
        OneSignal.SERVICE_WORKER_UPDATER_PATH = "OneSignalSDKUpdaterWorker.js.php";
                      OneSignal.SERVICE_WORKER_PATH = "OneSignalSDKWorker.js.php";
                      OneSignal.SERVICE_WORKER_PARAM = { scope: "/" };
        OneSignal.setDefaultNotificationUrl("https://www.giantfreakinrobot.com");
        var oneSignal_options = {};
        window._oneSignalInitOptions = oneSignal_options;

        oneSignal_options['wordpress'] = true;
oneSignal_options['appId'] = '0da4479e-40de-41e6-8a92-544497ed15c4';
oneSignal_options['allowLocalhostAsSecureOrigin'] = true;
oneSignal_options['welcomeNotification'] = { };
oneSignal_options['welcomeNotification']['disable'] = true;
oneSignal_options['path'] = "https://www.giantfreakinrobot.com/wp-content/plugins/onesignal-free-web-push-notifications/sdk_files/";
oneSignal_options['safari_web_id'] = "web.onesignal.auto.1bb493cc-6f2b-4253-90e1-02d85a4b9e78";
oneSignal_options['persistNotification'] = false;
oneSignal_options['promptOptions'] = { };
oneSignal_options['promptOptions']['actionMessage'] = "Giant Freakin Robot will notify you when we post a story you want.";
oneSignal_options['promptOptions']['acceptButtonText'] = "CONTINUE";
oneSignal_options['promptOptions']['cancelButtonText'] = "EXIT";
oneSignal_options['promptOptions']['siteName'] = "http://www.giantfreakinrobot.com";
                OneSignal.init(window._oneSignalInitOptions);
                OneSignal.showSlidedownPrompt();      });

      function documentInitOneSignal() {
        var oneSignal_elements = document.getElementsByClassName("OneSignal-prompt");

        var oneSignalLinkClickHandler = function(event) { OneSignal.push(['registerForPushNotifications']); event.preventDefault(); };        for(var i = 0; i < oneSignal_elements.length; i++)
          oneSignal_elements[i].addEventListener('click', oneSignalLinkClickHandler, false);
      }

      if (document.readyState === 'complete') {
           documentInitOneSignal();
      }
      else {
           window.addEventListener("load", function(event){
               documentInitOneSignal();
          });
      }
    </script>

<script src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js?client=ca-pub-5908537285259979" crossorigin="anonymous"></script>

<link rel="icon" href="https://www.giantfreakinrobot.com/wp-content/uploads/2019/11/cropped-GFR-Logo-1-32x32.jpg" sizes="32x32" />
<link rel="icon" href="https://www.giantfreakinrobot.com/wp-content/uploads/2019/11/cropped-GFR-Logo-1-192x192.jpg" sizes="192x192" />
<link rel="apple-touch-icon" href="https://www.giantfreakinrobot.com/wp-content/uploads/2019/11/cropped-GFR-Logo-1-180x180.jpg" />
<meta name="msapplication-TileImage" content="https://www.giantfreakinrobot.com/wp-content/uploads/2019/11/cropped-GFR-Logo-1-270x270.jpg" />
<style id="wp-custom-css">
			.pw-pos-top.is-docked {
	margin-top: 65px !important;
}

body.single .entry .wp-block-quote {
	border-left: 5px solid #969696;
	padding-left: 20px; 
}

body.single .entry .wp-block-quote p {
	font-size: 28px !important;
	color: 343434;
	display: block;
	line-height: 30px;
	font-style: normal;
	padding-right: 20px;
}

body.single .entry .wp-block-quote cite {
	font-size: 14px;
	    color: #969696;
		}		</style>

<link rel="preload" href="https://stackpath.bootstrapcdn.com/bootstrap/4.1.1/js/bootstrap.min.js" as="script">
<link rel="preload" href="https://www.giantfreakinrobot.com/wp-content/themes/face3-gfr/assets/js/main.min.js?ver=1.1.0" as="script">
<link rel="preload" href="https://www.giantfreakinrobot.com/wp-content/themes/twentynineteen/js/priority-menu.js?ver=20181214" as="script">
<link rel="preload" href="https://www.giantfreakinrobot.com/wp-content/themes/twentynineteen/js/touch-keyboard-navigation.js?ver=20181231" as="script">
<link rel="preload" href="/wp-includes/js/wp-embed.min.js" as="script">
<link rel="preload" href="https://cdn.onesignal.com/sdks/OneSignalSDK.js#asyncload" as="script">
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-145028702-1"></script>
<script>
    window.dataLayer = window.dataLayer || [ ];
    function gtag () {
        dataLayer.push( arguments );
    }
    gtag( 'js', new Date() );
    gtag( 'config', 'UA-145028702-1' );
</script> 
<meta name="p:domain_verify" content="fc00e490a42be9ae12e4d56349187cc2" />

<meta property="fb:pages" content="89650649583" />
<meta name="google-site-verification" content="wMkK-uYT4GgevZbCg_eeUwlTpkH4YO8pyqsAEBNm3DY" />

<script type="text/javascript">
        var tyche = { mode: 'tyche', config: '//config.playwire.com/1024236/v2/websites/72570/banner.json' }
    </script>
<script id="tyche" src="//cdn.intergient.com/pageos/pageos.js" type="text/javascript"></script>

<style type="text/css">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</style>

</head>
<body class="post-template-default single single-post postid-308445 single-format-standard wp-custom-logo wp-embed-responsive singular image-filters-enabled">
<form class="form-inline my-2 my-md-0 d-none">
<input class="form-control" type="text" placeholder="Search" aria-label="Search">
</form>
<div class="ad_container afs_ads" style="width: 730px; height: 90px; position: absolute; left: -11111px; top: -111px; pointer-events: none;"></div>
<div class="b-anterior">
<div class="dtads-slot dtads-slot-atn dtads-desktop dtads-is-rendered" id="dtads-atn-avyydchwhd5" data-google-query-id="CLOWn6vBlOUCFc0XhgodNekBAQ">
<div id="google_ads_iframe_/5611/dt.dgt.www_0__container__" style="border: 0pt none; margin: auto; text-align: center; width: 930px; height: 90px;max-width: 100%;"></div>
</div>
<div class="dtads-slot dtads-slot-atn-tablet dtads-tablet"></div>
<div class="dtads-slot dtads-out-of-page dtads-desktop dtads-tablet dtads-mobile" id="dtads-out-of-page-407ml99e97h" data-google-query-id="CM2F77vAlOUCFeiGWgUdxSIBjQ"><div id="google_ads_iframe_/5611/dt.dgt.www_1__container__" style="border: 0pt none; margin: auto; text-align: center; width: 1px; height: 1px;"></div></div>
</div>
<header>
<meta name="p:domain_verify" content="fc00e490a42be9ae12e4d56349187cc2" />
<nav class="navbar navbar-expand-lg navbar-dark bg-dark-gray" role="navigation">
<div class="container">
<a class="navbar-brand" href="https://www.giantfreakinrobot.com"><img alt="Giant Freakin Robot" height="56" width="188" src="/wp-content/themes/face3-gfr/assets/images/GFR-logo-dev-b6030d-4.1.png" /></a>
<button class="navbar-toggler second-button" type="button" data-toggle="collapse" data-target="#navbarsExample07" aria-controls="navbarsExample07" aria-expanded="false" aria-label="Toggle navigation">
<div class="animated-icon2">
<span></span><span></span><span></span><span></span>
</div>
</button>
<div class="collapse navbar-collapse" id="navbarsExample07">
<div id="bs-example-navbar-collapse-1" class="navbar-nav m-md-auto"><ul id="menu-top-menu" class="nav navbar-nav m-md-auto"><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-122507" class="d-block d-lg-none no-both search menu-item menu-item-type-custom menu-item-object-custom menu-item-122507 nav-item"><a href="#" class="nav-link"><i class="fas fa-search"></i></a></li>
<li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-122363" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children dropdown active menu-item-122363 nav-item"><a title="Movies and TV News" href="https://www.giantfreakinrobot.com/category/ent" aria-haspopup="true" aria-expanded="false" class="nav-link" id="menu-item-dropdown-122363">Movies &#038; TV</a>
<ul class="dropdown-menu" aria-labelledby="menu-item-dropdown-122363" role="menu">
<li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-256319" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-256319 nav-item"><a title="On Netflix" href="https://www.giantfreakinrobot.com/topic/netflix" class="dropdown-item">On Netflix</a></li>
<li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-252032" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-252032 nav-item"><a title="New Movies &#038; TV Coming Soon" href="https://www.giantfreakinrobot.com/topic/coming-soon" class="dropdown-item">Coming Soon</a></li>
<li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-256322" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-256322 nav-item"><a title="Confirmed Scoops" href="https://www.giantfreakinrobot.com/topic/confirmed" class="dropdown-item">Confirmed Exclusives</a></li>
<li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-258090" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-258090 nav-item"><a title="reviews" href="https://www.giantfreakinrobot.com/topic/reviews" class="dropdown-item">Reviews</a></li>
</ul>
</li>
<li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-140178" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-140178 nav-item"><a title="Culture News" href="https://www.giantfreakinrobot.com/category/cltr" class="nav-link">Culture</a></li>
<li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-221352" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children dropdown menu-item-221352 nav-item"><a title="Video Games News" href="https://www.giantfreakinrobot.com/category/games" aria-haspopup="true" aria-expanded="false" class="nav-link" id="menu-item-dropdown-221352">Games</a>
<ul class="dropdown-menu" aria-labelledby="menu-item-dropdown-221352" role="menu">
<li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-256334" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-256334 nav-item"><a title="Nintendo News" href="https://www.giantfreakinrobot.com/topic/nintendo" class="dropdown-item">Nintendo</a></li>
<li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-256331" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-256331 nav-item"><a title="Playstation News" href="https://www.giantfreakinrobot.com/topic/playstation" class="dropdown-item">Playstation</a></li>
<li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-256328" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-256328 nav-item"><a title="XBox Games" href="https://www.giantfreakinrobot.com/topic/xbox" class="dropdown-item">XBox</a></li>
</ul>
</li>
<li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-221358" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children dropdown menu-item-221358 nav-item"><a title="Science and Technology news" href="https://www.giantfreakinrobot.com/category/sci,tech" aria-haspopup="true" aria-expanded="false" class="nav-link" id="menu-item-dropdown-221358">Science &#038; Tech</a>
<ul class="dropdown-menu" aria-labelledby="menu-item-dropdown-221358" role="menu">
<li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-256337" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-256337 nav-item"><a title="Science news" href="https://www.giantfreakinrobot.com/category/sci" class="dropdown-item">Science News</a></li>
<li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-256340" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-256340 nav-item"><a title="Tech News" href="https://www.giantfreakinrobot.com/category/tech" class="dropdown-item">Tech News</a></li>
<li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-256325" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-256325 nav-item"><a title="snakes" href="https://www.giantfreakinrobot.com/topic/snakes" class="dropdown-item">Snakes Gone Wild</a></li>
</ul>
</li>
</ul></div>
<div id="bs-example-navbar-collapse-2" class="menu-top-social-container"><ul id="menu-top-social" class="nav navbar-nav m-auto"><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-122215" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-122215 nav-item"><a title="GFR Facebook" href="https://www.facebook.com/giantfreakinrobot/" class="nav-link"><i class="fab fa-facebook-f"></i></a></li>
<li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-122217" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-122217 nav-item"><a title="GFR Twitter" href="https://twitter.com/GFRobot" class="nav-link"><i class="fab fa-twitter"></i></a></li>
<li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-122214" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-122214 nav-item"><a href="https://flipboard.com/@gfrobot" class="nav-link"><i class="fab fa-flipboard"></i></a></li>
<li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-122216" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-122216 nav-item"><a title="Follow Us On Google news" href="https://news.google.com/publications/CAAqBwgKMOKklgswxcmtAw" class="nav-link"><i class="fab fa-google"></i></a></li>
<li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-122218" class="d-none d-lg-block menu-item menu-item-type-custom menu-item-object-custom menu-item-122218 nav-item"><a href="#" class="nav-link"><i class="fas fa-search"></i></a></li>
</ul></div> </div>
</div>
</nav>
<div class="search-bar bg-dark-gray fade-in">
<form class="search" action="https://www.giantfreakinrobot.com/" method="get">
<input type='text' name='s' autocomplete="off">
<input type='submit' value="Search">
</form>
</div>
<meta name="pocket-site-verification" content="5665f2fa77c896be0baea4ea51492e" />
</header>
<main role="main">
<div class="container">

<div style="margin-top:-30px">

</div>

<div class="pw-leaderboard-atf-container">
<div class="pw-ph-leaderboard" data-pw-desk="leaderboard_atf" data-pw-mobi="leaderboard_atf">
</div>
</div> <div style="height:20px">

</div>

<div class="row">
<div class="col-lg-8">

<article id="post-308445" class="row no-gutters post-308445 post type-post status-publish format-standard has-post-thumbnail hentry category-ent entry">

<div class="col-12 text-md-left">
<div class="breadcrumbs" typeof="BreadcrumbList" vocab="https://schema.org/">
<span property="itemListElement" typeof="ListItem"><a property="item" typeof="WebPage" title="Go to GIANT FREAKIN ROBOT." href="https://www.giantfreakinrobot.com" class="home"><span property="name">GIANT FREAKIN ROBOT</span></a><meta property="position" content="1"></span> &gt; <span property="itemListElement" typeof="ListItem"><a property="item" typeof="WebPage" title="Go to the Movies &amp; TV category archives." href="https://www.giantfreakinrobot.com/category/ent" class="taxonomy category" aria-current="page"><span property="name">Movies &amp; TV</span></a><meta property="position" content="2"></span></div> <h1 class="entry-title"><a href="https://www.giantfreakinrobot.com/ent/guardians-of-the-galaxy-3-yondu.html" rel="bookmark">Guardians Of The Galaxy 3 Won’t See A Crucial Actor Return</a></h1>
<p class="font-weight-normal about-author">
By <a href="https://www.giantfreakinrobot.com/author/dylanbalde" title="Dylan Balde">Dylan Balde</a>
| <span>8 seconds ago</span> </p>
<p class="font-weight-normal">
<figure class="wp-block-image size-large"><img loading="lazy" width="900" height="474" src="https://www.giantfreakinrobot.com/wp-content/uploads/2019/12/guardians-1-900x474.jpg" alt="guardians of the galaxy 3" class="wp-image-124957" /></figure>
<p>Yondu is permanently sitting out Peter Quill’s final romp through the cosmos, James Gunn <a href="https://twitter.com/JamesGunn/status/1455577060227928064?s=20" target="_blank" rel="noreferrer noopener">tweeted out</a> this morning. The writer and director of <em>Guardians of the Galaxy 3</em> responded to a fan overestimating the reach of Yondu Udonta’s Yaka Arrow by reminding him not even advanced Centaurian technology could keep Star-Lord’s adoptive space daddy alive, to which user @stefd75 replied, “It’s the Marvel universe, no one stays dead… apart [from] Uncle Ben.” Gunn decided to put a swift end to any and all speculation about Yondu’s (Michael Rooker) return by reiterating that as long as the Guardians remain in his care, no magic in the Marvel Cinematic Universe and beyond can bring the fallen Ravager back from the grave. No plot would ever justify disrespecting Yondu’s sacrifice all the way back in <em>Guardians of the Galaxy Vol. 2</em>.</p><div class='code-block code-block-1' style='margin: 8px 0; clear: both;'>
<div class="pw-in-article-ad-container">
<div class="pw-in-article">
<div data-pw-desk="med_rect_btf" data-pw-mobi="med_rect_btf">
</div>
</div>
</div></div>
<p>This means Yondu will not be rearing his red fin just in time for <em>Guardians of the Galaxy 3</em>. Check out James Gunn’s impassioned Twitter response to @stefd75 below:</p>
<figure class="wp-block-embed is-type-rich is-provider-twitter wp-block-embed-twitter"><div class="wp-block-embed__wrapper">
<blockquote class="twitter-tweet" data-width="550" data-dnt="true"><p lang="en" dir="ltr">As I&#39;ve said many times before, as long as I&#39;m a part of the Guardians, Yondu is dead, 100%, forever, no magic resurrections. Any other way would be belittling his sacrifice and what his story means to so many people. <a href="https://t.co/QveTjUi2nm">https://t.co/QveTjUi2nm</a></p>&mdash; James Gunn (@JamesGunn) <a href="https://twitter.com/JamesGunn/status/1455577060227928064?ref_src=twsrc%5Etfw">November 2, 2021</a></blockquote><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
</div></figure>
<p><em>Guardians of the Galaxy Vol. 2</em> saw Peter Quill (Chris Pratt) reunite with his estranged father, the Celestial Ego (Kurt Russell). This megalomaniac alien deity is obsessed with spreading his literal seed across the universe and terraforming other planets in his own image. He assumed a human form meeting Quill’s mother Meredith in the 1980s and ended up siring a child, with whom he intended to activate hundreds of viable planets. Not counting the video replay of Eson the Searcher mowing down civilizations with the Power Stone in the first <em>Guardians</em>, Ego was the Marvel Cinematic Universe’s first mention of a proper Celestial before Chloé Zhao <a href="https://www.giantfreakinrobot.com/ent/eternals-review-sloppy-overstuffed-and-indecisive.html">introduced</a> the race’s more benevolent offshoot in <em>Eternals</em>. <em>Guardians of the Galaxy Vol. 3</em> will presumably take off from there, a growing multiverse where Deviants and Celestials are commonplace additions to life on Earth and beyond.</p>
<p>Star-Lord eventually loses his Celestial abilities when the Guardians set off a bomb from within Ego, killing him and his legacy along with it. Yondu Udonta rescues Quill from the burning remains of Ego’s planet shortly before it collapses into a black hole, using his spacesuit on Star-Lord at the cost of his own life. It was an honorable death for a Ravager that had lived a whole existence leveling communities, chasing bounties, and engaging in murder and petty theft, and James Gunn intends to keep it that way for <em>Guardians of the Galaxy Vol. 3</em>.</p>
<p>The plot of <em>Guardians of the Galaxy 3</em> remains as much of a mystery as the circumstances of Peter Quill’s inevitable departure from the franchise. <a href="https://www.giantfreakinrobot.com/ent/chris-pratt-guardians-of-the-galaxy-3.html">Is he dying</a> or handing off leadership of the Guardians to Thor or Adam Warlock? Or is he continuing with life as an intergalactic peacekeeper and simply fading from the main MCU narrative? We don’t know. The only thing James Gunn has made one-hundred percent clear is this is the <a href="https://www.giantfreakinrobot.com/ent/james-gunn-guardians-of-the-galaxy-3-last-movie.html">end of the road</a> for him with regards to anything Guardians-related.</p>
<p>Kevin Feige may still use the same characters in the future, effectively continuing to hire Gunn on a case-by-case, per-consultant basis, but as far as solo movies around the original space family are concerned, the <em>Peacemaker</em> writer is done. Dave Bautista has similarly alluded to the <a href="https://www.giantfreakinrobot.com/ent/dave-bautista-marvel-leaving.html">end of Drax</a> the Destroyer after <em>Guardians of the Galaxy Vol. 3</em>, explaining there is no reason to continue staying in the MCU with Gunn no longer actively involved. The rest of the cast has stayed mum on the subject of the Guardians’ future, which is probably for the best until <em>Thor: Love and Thunder</em> <a href="https://www.imdb.com/title/tt10648342/" target="_blank" rel="noreferrer noopener">comes out</a>.</p>
<figure class="wp-block-image size-large"><img loading="lazy" width="900" height="599" src="https://www.giantfreakinrobot.com/wp-content/uploads/2021/07/dave-bautista-drax-1-900x599.jpg" alt="dave bautista" class="wp-image-254246" srcset="https://www.giantfreakinrobot.com/wp-content/uploads/2021/07/dave-bautista-drax-1-900x599.jpg 900w, https://www.giantfreakinrobot.com/wp-content/uploads/2021/07/dave-bautista-drax-1-578x385.jpg 578w, https://www.giantfreakinrobot.com/wp-content/uploads/2021/07/dave-bautista-drax-1-768x511.jpg 768w, https://www.giantfreakinrobot.com/wp-content/uploads/2021/07/dave-bautista-drax-1.jpg 1500w" sizes="(max-width: 900px) 100vw, 900px" /></figure>
<div class='code-block code-block-7' style='margin: 8px 0; clear: both;'>
<div class="pw-in-article-relevant-container">
<div class="pw-relevant-article">
<div></div>
</div>
</div></div>
<p><em>Guardians of the Galaxy Vol. 3</em> will start shooting later this month under the working title <em>Hot Christmas</em>. <a href="https://www.giantfreakinrobot.com/ent/guardians-of-the-galaxy-3-storyboards.html">Production</a> is expected to last well into 2022 after close to six months of filming. The final leg in the Guardians of the Galaxy’s trilogy stars Chris Pratt as Star-Lord, Zoe Saldana as Gamora, Dave Bautista as Drax, Bradley Cooper as Rocket Raccoon, Vin Diesel as Groot, Karen Gillan as Nebula, Pom Klementieff as Mantis, Sean Gunn as Kraglin Obfonteri, and newcomer Will Poulter as <a href="https://www.giantfreakinrobot.com/ent/will-poulter-guardians-of-the-galaxy-3.html">Adam Warlock</a>. Chris Hemsworth <a href="https://www.giantfreakinrobot.com/ent/exclusive-chris-hemsworth-marvel.html">may also reprise</a> the role of Thor Odinson. The film comes out on May 5, 2023.</p>

</p>


<div class="pw-med-rect-btf-container">
<div class="pw-ph-med-rect" data-pw-desk="med_rect_btf" data-pw-mobi="med_rect_btf">
</div>
</div> 

<div id="zergnet-widget-82200"></div>
<script language="javascript" type="text/javascript">
    (function() {
        var zergnet = document.createElement('script');
        zergnet.type = 'text/javascript'; zergnet.async = true;
        zergnet.src = (document.location.protocol == "https:" ? "https:" : "http:") + '//www.zergnet.com/zerg.js?id=82200';
        var znscr = document.getElementsByTagName('script')[0];
        znscr.parentNode.insertBefore(zergnet, znscr);
    })();
</script>

<div class='yarpp yarpp-related yarpp-related-website yarpp-template-yarpp-template-example'>
<div class="row no-gutters related-article">
<div class="col-12 text-left">
<h3>related articles</h3>
</div>
<div class="col-12 items">
<div class="row">
<a href="https://www.giantfreakinrobot.com/ent/iconic-rock-star-marvel-universe-henry-rollins.html" class="col-6 col-md item">

<img src="https://www.giantfreakinrobot.com/wp-content/uploads/2021/09/henry-rollins-guitar-rock-e1632339689563-200x200.jpg" class="img-fluid w-100" />
<p>An Iconic Rock Star Is Joining The Marvel Universe</p>

</a>
<a href="https://www.giantfreakinrobot.com/ent/daniel-craig-honor.html" class="col-6 col-md item">

<img src="https://www.giantfreakinrobot.com/wp-content/uploads/2021/06/JAMES-BOND-DANIEL-CRAIG-1-200x200.jpg" class="img-fluid w-100" />
<p>Daniel Craig Given Huge Honor By British Military</p>

</a>
<a href="https://www.giantfreakinrobot.com/ent/hollywood-pandemic-protocols-strike.html" class="col-6 col-md item">

<img src="https://www.giantfreakinrobot.com/wp-content/uploads/2021/09/hollywood-sign-e1632834432718-200x200.jpg" class="img-fluid w-100" />
<p>Hollywood Pandemic Protocols Expiring, Huge Strike On The Horizon</p>

</a>
<a href="https://www.giantfreakinrobot.com/ent/danny-devito-wolverine.html" class="col-6 col-md item">

<img src="https://www.giantfreakinrobot.com/wp-content/uploads/2021/09/danny-devito-1-200x200.jpg" class="img-fluid w-100" />
<p>See Danny DeVito As Wolverine With Claws Out</p>

</a>
</div>
</div>
</div>
</div>
<div class="prev_cmn_ad_tag_bottom_article">
</div>
</div>

</article>
 </div>
<div id="sidebar" class="d-md-block col-lg-4 col-xs-12">
<div class="prev_cmn_ad_tag_top_sidebar"></div>
<h2 class="trending ">Trending</h2>
<div class="posts-trending ">

<div id="post-308445" class="row no-gutters post-308445 post type-post status-publish format-standard has-post-thumbnail hentry category-ent entry">

<div class="col-12">
<a href="https://www.giantfreakinrobot.com/ent/guardians-of-the-galaxy-3-yondu.html">

<img width="385" height="200" src="https://www.giantfreakinrobot.com/wp-content/uploads/2019/12/guardians-1-e1635979528451-385x200.jpg" class="img-fluid w-100 wp-post-image" alt="guardians of the galaxy 3" loading="lazy" /> <h4 class="entry-title">Guardians Of The Galaxy 3 Won’t See A Crucial Actor Return</h4> <p class="author"><span>8 seconds ago</span></p>
</a>
</div>

</div>


<div id="post-308487" class="row no-gutters post-308487 post type-post status-publish format-standard has-post-thumbnail hentry category-cltr tag-amber-heard tag-aquaman tag-aquaman-and-the-lost-kingdom tag-instagram tag-mera entry">

<div class="col-12">
<a href="https://www.giantfreakinrobot.com/cltr/amber-heard-sexy-workout-photo.html">

<img width="385" height="200" src="https://www.giantfreakinrobot.com/wp-content/uploads/2021/04/amber-heard-underwear-e1635978895894-385x200.jpg" class="img-fluid w-100 wp-post-image" alt="amber heard underwear" loading="lazy" srcset="https://www.giantfreakinrobot.com/wp-content/uploads/2021/04/amber-heard-underwear-e1635978895894-385x200.jpg 385w, https://www.giantfreakinrobot.com/wp-content/uploads/2021/04/amber-heard-underwear-e1635978895894-900x468.jpg 900w" sizes="(max-width: 385px) 100vw, 385px" /> <h4 class="entry-title">Amber Heard Shares A Sweaty, Sexy Workout Photo</h4> <p class="author"><span>14 mins ago</span></p>
</a>
</div>

</div>


<div id="post-308442" class="row no-gutters post-308442 post type-post status-publish format-standard has-post-thumbnail hentry category-cltr tag-cancel-culture tag-elijah-wood tag-lord-of-the-rings tag-nft tag-the-lord-of-the-rings tag-twitter entry">

<div class="col-12">
<a href="https://www.giantfreakinrobot.com/cltr/elijah-wood-racism-nft.html">

<img width="385" height="200" src="https://www.giantfreakinrobot.com/wp-content/uploads/2021/09/elijah-wood-is-open-to-return-for-a-frodo-cameo-in-amazons-lord-of-the-rings-series-social-385x200.jpeg" class="img-fluid w-100 wp-post-image" alt="elijah wood hobbit" loading="lazy" srcset="https://www.giantfreakinrobot.com/wp-content/uploads/2021/09/elijah-wood-is-open-to-return-for-a-frodo-cameo-in-amazons-lord-of-the-rings-series-social-385x200.jpeg 385w, https://www.giantfreakinrobot.com/wp-content/uploads/2021/09/elijah-wood-is-open-to-return-for-a-frodo-cameo-in-amazons-lord-of-the-rings-series-social-900x468.jpeg 900w" sizes="(max-width: 385px) 100vw, 385px" /> <h4 class="entry-title">Elijah Wood Under Attack, Embroiled In Racism Controversy</h4> <p class="author"><span>25 mins ago</span></p>
</a>
</div>

</div>


<div id="post-308424" class="row no-gutters post-308424 post type-post status-publish format-standard has-post-thumbnail hentry category-ent tag-alec-baldwin tag-rust entry">

<div class="col-12">
<a href="https://www.giantfreakinrobot.com/ent/alec-baldwin-shooting-sabotage.html">

<img width="385" height="200" src="https://www.giantfreakinrobot.com/wp-content/uploads/2021/10/alec-baldwin-3-1200x800-1-e1635282669438-385x200.jpeg" class="img-fluid w-100 wp-post-image" alt="alec baldwin shooting" loading="lazy" srcset="https://www.giantfreakinrobot.com/wp-content/uploads/2021/10/alec-baldwin-3-1200x800-1-e1635282669438-385x200.jpeg 385w, https://www.giantfreakinrobot.com/wp-content/uploads/2021/10/alec-baldwin-3-1200x800-1-e1635282669438-900x468.jpeg 900w" sizes="(max-width: 385px) 100vw, 385px" /> <h4 class="entry-title">Alec Baldwin Fatal Shooting Accident Was Sabotage?</h4> <p class="author"><span>2 hours ago</span></p>
</a>
</div>

</div>

</div>
<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<div style="margin-top:-50px;">

</div>

<div class="pw-med-rect-btf-container">
<div class="pw-ph-med-rect" data-pw-desk="med_rect_btf" data-pw-mobi="med_rect_btf">
</div>
</div> <div style="height:30px">

</div>

<h2 class="top-stories">Top Stories</h2>
<div class="posts-top-stories">

<div id="post-307266" class="row no-gutters post-308391 post type-post status-publish format-standard has-post-thumbnail hentry category-cltr tag-peter-scolari tag-tom-hanks entry">

<div class="col-12">
<a href="https://www.giantfreakinrobot.com/cltr/olivia-wilde-dolly-parton-halloween.html">

<img width="385" height="200" src="https://www.giantfreakinrobot.com/wp-content/uploads/2019/10/olivia-wilde-385x200.jpg" class="img-fluid wp-post-image" alt="olivia wilde" loading="lazy" srcset="https://www.giantfreakinrobot.com/wp-content/uploads/2019/10/olivia-wilde-385x200.jpg 385w, https://www.giantfreakinrobot.com/wp-content/uploads/2019/10/olivia-wilde-900x468.jpg 900w" sizes="(max-width: 385px) 100vw, 385px" /> <h4 class="entry-title">See Olivia Wilde Dressed As A Sexy Dolly Parton For Halloween</h4>
<p class="author"><span>3 days ago</span></p>
</a>
</div>

</div>


<div id="post-307233" class="row no-gutters post-308391 post type-post status-publish format-standard has-post-thumbnail hentry category-cltr tag-peter-scolari tag-tom-hanks entry">

<div class="col-12">
<a href="https://www.giantfreakinrobot.com/ent/willem-dafoe-spider-man-no-way-home-goblin.html">

<img width="385" height="200" src="https://www.giantfreakinrobot.com/wp-content/uploads/2021/03/willem-dafoe-385x200.jpg" class="img-fluid wp-post-image" alt="willem dafoe" loading="lazy" srcset="https://www.giantfreakinrobot.com/wp-content/uploads/2021/03/willem-dafoe-385x200.jpg 385w, https://www.giantfreakinrobot.com/wp-content/uploads/2021/03/willem-dafoe-900x468.jpg 900w" sizes="(max-width: 385px) 100vw, 385px" /> <h4 class="entry-title">See Willem Dafoe’s New Green Goblin Look For Spider-Man: No Way Home</h4>
<p class="author"><span>3 days ago</span></p>
</a>
</div>

</div>


<div id="post-307302" class="row no-gutters post-308391 post type-post status-publish format-standard has-post-thumbnail hentry category-cltr tag-peter-scolari tag-tom-hanks entry">

<div class="col-12">
<a href="https://www.giantfreakinrobot.com/ent/sylvester-stallone-expendables.html">

<img width="385" height="200" src="https://www.giantfreakinrobot.com/wp-content/uploads/2021/04/sylvester-stallone-385x200.jpg" class="img-fluid wp-post-image" alt="sylvester stallone" loading="lazy" srcset="https://www.giantfreakinrobot.com/wp-content/uploads/2021/04/sylvester-stallone-385x200.jpg 385w, https://www.giantfreakinrobot.com/wp-content/uploads/2021/04/sylvester-stallone-900x468.jpg 900w" sizes="(max-width: 385px) 100vw, 385px" /> <h4 class="entry-title">Stallone Quitting His Biggest Franchise? Passes The Baton To His Successor</h4>
<p class="author"><span>2 days ago</span></p>
</a>
</div>

</div>


<div id="post-307296" class="row no-gutters post-308391 post type-post status-publish format-standard has-post-thumbnail hentry category-cltr tag-peter-scolari tag-tom-hanks entry">

<div class="col-12">
<a href="https://www.giantfreakinrobot.com/cltr/amber-heard-investigation-australia.html">

<img width="385" height="200" src="https://www.giantfreakinrobot.com/wp-content/uploads/2021/02/amber-heard-disney-princess-385x200.jpg" class="img-fluid wp-post-image" alt="amber heard" loading="lazy" srcset="https://www.giantfreakinrobot.com/wp-content/uploads/2021/02/amber-heard-disney-princess-385x200.jpg 385w, https://www.giantfreakinrobot.com/wp-content/uploads/2021/02/amber-heard-disney-princess-900x468.jpg 900w" sizes="(max-width: 385px) 100vw, 385px" /> <h4 class="entry-title">Amber Heard Is Under Investigation For A Serious Offense</h4>
<p class="author"><span>2 days ago</span></p>
</a>
</div>

</div>


<div id="post-307158" class="row no-gutters post-308391 post type-post status-publish format-standard has-post-thumbnail hentry category-cltr tag-peter-scolari tag-tom-hanks entry">

<div class="col-12">
<a href="https://www.giantfreakinrobot.com/ent/anthony-mackie-captain-america-2.html">

<img width="385" height="200" src="https://www.giantfreakinrobot.com/wp-content/uploads/2021/03/falconmackie-385x200.jpeg" class="img-fluid wp-post-image" alt="falcon &amp; winter soldier captain america 4 disney sam anthony mackie" loading="lazy" srcset="https://www.giantfreakinrobot.com/wp-content/uploads/2021/03/falconmackie-385x200.jpeg 385w, https://www.giantfreakinrobot.com/wp-content/uploads/2021/03/falconmackie-900x468.jpeg 900w" sizes="(max-width: 385px) 100vw, 385px" /> <h4 class="entry-title">See Anthony Mackie&#8217;s Amazing New Look For Captain America</h4>
<p class="author"><span>4 days ago</span></p>
</a>
</div>

</div>

</div>

<div style="margin-top:-50px;">

</div>

<div class="pw-med-rect-btf-container">
<div class="pw-ph-med-rect" data-pw-desk="med_rect_btf" data-pw-mobi="med_rect_btf">
</div>
</div> <div style="height:30px">

</div>

<div class="sidebar-widget">
<h2 class="must-read">Must Read</h2>
<div class="posts-must-read">

<div id="post-265944" class="row no-gutters post-308424 post type-post status-publish format-standard has-post-thumbnail hentry category-ent tag-alec-baldwin tag-rust entry">

<div class="col-12">
<a href="https://www.giantfreakinrobot.com/ent/the-best-star-trek-starships.html">

<img width="385" height="200" src="https://www.giantfreakinrobot.com/wp-content/uploads/2021/08/enterprise-refit-385x200.jpeg" class="img-fluid wp-post-image" alt="" loading="lazy" srcset="https://www.giantfreakinrobot.com/wp-content/uploads/2021/08/enterprise-refit-385x200.jpeg 385w, https://www.giantfreakinrobot.com/wp-content/uploads/2021/08/enterprise-refit-900x468.jpeg 900w" sizes="(max-width: 385px) 100vw, 385px" /> <h4 class="entry-title">The Best Star Trek Starships</h4>
</a>
</div>

</div>


<div id="post-122980" class="row no-gutters post-308424 post type-post status-publish format-standard has-post-thumbnail hentry category-ent tag-alec-baldwin tag-rust entry">

<div class="col-12">
<a href="https://www.giantfreakinrobot.com/ent/the-matrix-4-all.html">

<img width="385" height="200" src="https://www.giantfreakinrobot.com/wp-content/uploads/2020/08/matrixrope-385x200.jpg" class="img-fluid wp-post-image" alt="" loading="lazy" srcset="https://www.giantfreakinrobot.com/wp-content/uploads/2020/08/matrixrope-385x200.jpg 385w, https://www.giantfreakinrobot.com/wp-content/uploads/2020/08/matrixrope-900x468.jpg 900w" sizes="(max-width: 385px) 100vw, 385px" /> <h4 class="entry-title">The Matrix 4: All About The Keanu Reeves Starring Sequel</h4>
</a>
</div>

</div>


<div id="post-149110" class="row no-gutters post-308424 post type-post status-publish format-standard has-post-thumbnail hentry category-ent tag-alec-baldwin tag-rust entry">

<div class="col-12">
<a href="https://www.giantfreakinrobot.com/cltr/tom-welling.html">

<img width="385" height="200" src="https://www.giantfreakinrobot.com/wp-content/uploads/2020/08/superman-385x200.jpg" class="img-fluid wp-post-image" alt="" loading="lazy" srcset="https://www.giantfreakinrobot.com/wp-content/uploads/2020/08/superman-385x200.jpg 385w, https://www.giantfreakinrobot.com/wp-content/uploads/2020/08/superman-900x468.jpg 900w" sizes="(max-width: 385px) 100vw, 385px" /> <h4 class="entry-title">Tom Welling: Why He Faded Away After Smallville</h4>
</a>
</div>

</div>


<div id="post-141100" class="row no-gutters post-308424 post type-post status-publish format-standard has-post-thumbnail hentry category-ent tag-alec-baldwin tag-rust entry">

<div class="col-12">
<a href="https://www.giantfreakinrobot.com/ent/eva-mendes.html">

<img width="385" height="200" src="https://www.giantfreakinrobot.com/wp-content/uploads/2020/06/evamendes-385x200.jpg" class="img-fluid wp-post-image" alt="eva mendes" loading="lazy" srcset="https://www.giantfreakinrobot.com/wp-content/uploads/2020/06/evamendes-385x200.jpg 385w, https://www.giantfreakinrobot.com/wp-content/uploads/2020/06/evamendes-900x468.jpg 900w" sizes="(max-width: 385px) 100vw, 385px" /> <h4 class="entry-title">Eva Mendes: Why She Stopped Acting And Why Its Ryan Gosling&#8217;s Fault</h4>
</a>
</div>

</div>

</div>
</div>
</div> </div>

<div style="height:20px">

</div>

<div class="pw-leaderboard-btf-container">
<div class="pw-ph-leaderboard" data-pw-desk="leaderboard_btf" data-pw-mobi="leaderboard_btf">
</div>
</div> <div style="height:20px">

</div>

</div>
</main>
<footer class="text-muted">
<div class="container">
<p class="float-right">
<a href="#" class="back-to-top">
<svg aria-hidden="true" focusable="false" data-prefix="fal" data-icon="chevron-up" role="img" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 448 512" class="svg-inline--fa fa-chevron-up fa-w-14 fa-2x"><path fill="currentColor" d="M4.465 366.475l7.07 7.071c4.686 4.686 12.284 4.686 16.971 0L224 178.053l195.494 195.493c4.686 4.686 12.284 4.686 16.971 0l7.07-7.071c4.686-4.686 4.686-12.284 0-16.97l-211.05-211.051c-4.686-4.686-12.284-4.686-16.971 0L4.465 349.505c-4.687 4.686-4.687 12.284 0 16.97z" class=""></path></svg>
</a>
</p>
</div>
</footer>
<footer class="no-gutters footer">
<div class="container">
<div class="row">
<div class="col-12 col-md-6 col-lg-3 column-1">
<a class="navbar-brand" href="https://www.giantfreakinrobot.com"><img loading="lazy" width="270" height="114" src="https://www.giantfreakinrobot.com/wp-content/themes/face3-gfr/assets/images/gfr-footer-logo.png" /></a>
<p>Giant Freakin Robot stomps into the future of everything that matters. We offer unique information that impacts everything you care most about in the world, all in one place.</p>
<h3>Affiliate Disclosure</h3>
<p>Giant Freakin Robot may get a commission from retail offers.</p>
<h3>Add Us on Social</h3>
<ul class="social">
<li><a href="https://www.facebook.com/giantfreakinrobot/" target="_blank"><i class="fab fa-facebook-f"></i></a></li>
<li><a href="https://twitter.com/GFRobot" target="_blank"><i class="fab fa-twitter"></i></a></li>
<li><a href="https://www.instagram.com/gfrobo/" target="_blank"><i class="fab fa-instagram"></i></a></li>
<li><a href="https://www.linkedin.com/company/gfrobot/" target="_blank"><i class="fab fa-linkedin"></i></a></li>
<li><a href="https://news.google.com/publications/CAAqBwgKMOKklgswxcmtAw" target="_blank"><i class="fab fa-google"></i></a></li>
<li><a href="https://www.youtube.com/c/GiantFreakinRobot" target="_blank"><i class="fab fa-youtube"></i></a></li>
<li><a href="https://flipboard.com/@GFRobot" target="_blank"><i class="fab fa-flipboard"></i></a></li>
<li><a href="/feed" target="_blank"><i class="fas fa-rss"></i></a></li>
</ul>
</div>
<div class="col-12 col-md-6 col-lg-3">
<h3>Who We Are</h3>
<div id="bs-example-navbar-collapse-2" class="menu-footer-1-container"><ul id="menu-footer-1" class="nav navbar-nav m-auto"><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-83887" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-83887 nav-item"><a title="About Us" href="https://www.giantfreakinrobot.com/about-us" class="nav-link">About Us</a></li>
<li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-122222" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-122222 nav-item"><a title="Privacy Policy" href="https://www.giantfreakinrobot.com/privacy-policy" class="nav-link">Privacy Policy</a></li>
<li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-122219" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-122219 nav-item"><a title="Contact Us" href="https://www.giantfreakinrobot.com/contact" class="nav-link">Contact Us</a></li>
<li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-122221" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-122221 nav-item"><a title="Careers" href="https://www.giantfreakinrobot.com/jobs" class="nav-link">Careers</a></li>
</ul></div> </div>
<div class="col-12 col-md-6 col-lg-3">
<h3>Must Read</h3>
<div id="bs-example-navbar-collapse-2" class="menu-footer-tags-container"><ul id="menu-footer-tags" class="nav navbar-nav m-auto"><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-153316" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-153316 nav-item"><a title="Star Wars News" href="https://www.giantfreakinrobot.com/topic/star-wars" class="nav-link">Star Wars News</a></li>
<li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-153317" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-153317 nav-item"><a title="Star Trek News" href="https://www.giantfreakinrobot.com/topic/star-trek" class="nav-link">Star Trek News</a></li>
<li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-222834" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-222834 nav-item"><a title="Superhero News" href="https://www.giantfreakinrobot.com/topic/marvel,dc-comics" class="nav-link">Superhero News</a></li>
<li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-258081" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-258081 nav-item"><a title="Dwayne Johnson News" href="https://www.giantfreakinrobot.com/topic/dwayne-johnson" class="nav-link">Dwayne Johnson News</a></li>
<li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-258096" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-258096 nav-item"><a title="henry cavill news" href="https://www.giantfreakinrobot.com/topic/henry-cavill" class="nav-link">Henry Cavill News</a></li>
<li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-258087" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-258087 nav-item"><a title="disney news" href="https://www.giantfreakinrobot.com/topic/disney" class="nav-link">Breaking Disney News</a></li>
</ul></div> </div>
</div>
</div>
</footer>
<link rel='stylesheet' id='yarppRelatedCss-css' href='https://www.giantfreakinrobot.com/wp-content/plugins/yet-another-related-posts-plugin/style/related.css?ver=5.27.5' media='all' />
<script src='https://stackpath.bootstrapcdn.com/bootstrap/4.1.1/js/bootstrap.min.js' id='bootstrap-js'></script>
<script src='https://www.giantfreakinrobot.com/wp-content/themes/face3-gfr/assets/js/main.min.js?ver=1.1.0' id='face3_gfr-main-script-js'></script>
<script src='https://www.giantfreakinrobot.com/wp-content/themes/twentynineteen/js/priority-menu.js?ver=20181214' id='twentynineteen-priority-menu-js'></script>
<script src='https://www.giantfreakinrobot.com/wp-content/themes/twentynineteen/js/touch-keyboard-navigation.js?ver=20181231' id='twentynineteen-touch-navigation-js'></script>
<script src='https://www.giantfreakinrobot.com/wp-includes/js/wp-embed.min.js?ver=787efb762acdfbea5a8cbc3af797c21d' id='wp-embed-js'></script>
<script src='https://cdn.onesignal.com/sdks/OneSignalSDK.js?ver=787efb762acdfbea5a8cbc3af797c21d' async='async' id='remote_sdk-js'></script>
<script>
	/(trident|msie)/i.test(navigator.userAgent)&&document.getElementById&&window.addEventListener&&window.addEventListener("hashchange",function(){var t,e=location.hash.substring(1);/^[A-z0-9_-]+$/.test(e)&&(t=document.getElementById(e))&&(/^(?:a|select|input|button|textarea)$/i.test(t.tagName)||(t.tabIndex=-1),t.focus())},!1);
	</script>


<script type="text/javascript">
    var _qevents = _qevents || [ ];

    ( function () {
        var elem = document.createElement( 'script' );
        elem.src = ( document.location.protocol == "https:" ? "https://secure" : "http://edge" ) + ".quantserve.com/quant.js";
        elem.async = true;
        elem.type = "text/javascript";
        var scpt = document.getElementsByTagName( 'script' )[0];
        scpt.parentNode.insertBefore( elem, scpt );
    } )();

    _qevents.push( {
        qacct: "p-889gzjdmeT5iw"
    } );
</script>
<noscript>
<div style="display:none;">
    <img src="//pixel.quantserve.com/pixel/p-889gzjdmeT5iw.gif" border="0" height="1" width="1" alt="Quantcast"/>
</div>
</noscript>
<script type="text/javascript">
    amzn_assoc_ad_type = "link_enhancement_widget";
    amzn_assoc_tracking_id = "gfrobot05-20";
    amzn_assoc_linkid = "633d40f62c281bfc721b203d2fa5c49a";
    amzn_assoc_placement = "";
    amzn_assoc_marketplace = "amazon";
    amzn_assoc_region = "US";
</script>
<script src="//ws-na.amazon-adsystem.com/widgets/q?ServiceVersion=20070822&Operation=GetScript&ID=OneJS&WS=1&MarketPlace=US"></script>

</body>
</html>