<!doctype html>
<html lang="en-US">
<head>
<meta charset="UTF-8" />
<meta name="viewport" content="width=device-width, initial-scale=1" />

<link rel="preconnect" href="https://config.playwire.com" crossorigin />
<link rel="preconnect" href="https://cdn.intergi.com" crossorigin />
<link rel="preconnect" href="https://cdn.intergient.com" crossorigin />
<link rel="preconnect" href="https://securepubads.g.doubleclick.net" crossorigin />
<link rel="preconnect" href="https://cdn.playwire.com" crossorigin />
<link rel="preconnect" href="https://cdn.video.playwire.com" crossorigin />
<link rel="preconnect" href="https://z.moatads.com" crossorigin />
<script src="https://btloader.com/tag?o=5150306120761344&upapi=true" async></script>

<link rel="preconnect" href="https://ws-na.amazon-adsystem.com" crossorigin />

<link rel="preload" href="https://fonts.gstatic.com/s/karla/v15/qkBbXvYC6trAT7RVLtyU5rZP.woff2" as="font" type="font/woff2" crossorigin>
<link rel="preload" href="https://fonts.gstatic.com/s/poppins/v15/pxiByp8kv8JHgFVrLCz7Z1xlFd2JQEk.woff2" as="font" type="font/woff2" crossorigin>
<link rel="profile" href="https://gmpg.org/xfn/11" />
<link rel="shortcut icon" type="image/png" href="https://www.giantfreakinrobot.com/wp-content/themes/face3-gfr/assets/images/gfr-favicon.png" />
<meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />

<title>A Classic &#039;80s Superhero Movie Reboot Just Finished Filming</title>
<meta name="description" content="After years of deliberations and delays, this &#039;80s reboot is finally happening and recently wrapped up its production in Bulgaria." />
<link rel="canonical" href="https://www.giantfreakinrobot.com/ent/toxic-avenger-filmed.html" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="A Classic &#039;80s Superhero Movie Reboot Just Finished Filming" />
<meta property="og:description" content="After years of deliberations and delays, this &#039;80s reboot is finally happening and recently wrapped up its production in Bulgaria." />
<meta property="og:url" content="https://www.giantfreakinrobot.com/ent/toxic-avenger-filmed.html" />
<meta property="og:site_name" content="GIANT FREAKIN ROBOT" />
<meta property="article:publisher" content="https://www.facebook.com/giantfreakinrobot" />
<meta property="article:published_time" content="2021-08-16T16:56:53+00:00" />
<meta property="og:image" content="https://www.giantfreakinrobot.com/wp-content/uploads/2021/08/1980s-superhero-action-icons-movie.jpg" />
<meta property="og:image:width" content="1920" />
<meta property="og:image:height" content="1080" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:creator" content="@GFRobot" />
<meta name="twitter:site" content="@GFRobot" />
<meta name="twitter:label1" content="Written by" />
<meta name="twitter:data1" content="Apeksha Bagchi" />
<meta name="twitter:label2" content="Est. reading time" />
<meta name="twitter:data2" content="3 minutes" />
<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://www.giantfreakinrobot.com/#organization","name":"GIANT FREAKIN ROBOT","url":"https://www.giantfreakinrobot.com/","sameAs":["https://www.facebook.com/giantfreakinrobot","https://www.instagram.com/gfrobo/","https://www.linkedin.com/company/gfrobot/","https://www.youtube.com/channel/UCR4if3TFE8RvtFf-HFlMu9w","https://www.pinterest.com/gfrobot/","https://twitter.com/GFRobot"],"logo":{"@type":"ImageObject","@id":"https://www.giantfreakinrobot.com/#logo","inLanguage":"en-US","url":"https://www.giantfreakinrobot.com/wp-content/uploads/2021/07/GFRlogo-scaled.jpg","contentUrl":"https://www.giantfreakinrobot.com/wp-content/uploads/2021/07/GFRlogo-scaled.jpg","width":2560,"height":1499,"caption":"GIANT FREAKIN ROBOT"},"image":{"@id":"https://www.giantfreakinrobot.com/#logo"}},{"@type":"WebSite","@id":"https://www.giantfreakinrobot.com/#website","url":"https://www.giantfreakinrobot.com/","name":"GIANT FREAKIN ROBOT","description":"Stomping into the future of everything.","publisher":{"@id":"https://www.giantfreakinrobot.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"https://www.giantfreakinrobot.com/?s={search_term_string}"},"query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://www.giantfreakinrobot.com/ent/toxic-avenger-filmed.html#primaryimage","inLanguage":"en-US","url":"https://www.giantfreakinrobot.com/wp-content/uploads/2021/08/1980s-superhero-action-icons-movie.jpg","contentUrl":"https://www.giantfreakinrobot.com/wp-content/uploads/2021/08/1980s-superhero-action-icons-movie.jpg","width":1920,"height":1080,"caption":"1980s toxic avenger"},{"@type":"WebPage","@id":"https://www.giantfreakinrobot.com/ent/toxic-avenger-filmed.html#webpage","url":"https://www.giantfreakinrobot.com/ent/toxic-avenger-filmed.html","name":"A Classic '80s Superhero Movie Reboot Just Finished Filming","isPartOf":{"@id":"https://www.giantfreakinrobot.com/#website"},"primaryImageOfPage":{"@id":"https://www.giantfreakinrobot.com/ent/toxic-avenger-filmed.html#primaryimage"},"datePublished":"2021-08-16T16:56:53+00:00","dateModified":"2021-08-16T16:56:53+00:00","description":"After years of deliberations and delays, this '80s reboot is finally happening and recently wrapped up its production in Bulgaria.","breadcrumb":{"@id":"https://www.giantfreakinrobot.com/ent/toxic-avenger-filmed.html#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://www.giantfreakinrobot.com/ent/toxic-avenger-filmed.html"]}]},{"@type":"BreadcrumbList","@id":"https://www.giantfreakinrobot.com/ent/toxic-avenger-filmed.html#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"GFR Home","item":"https://www.giantfreakinrobot.com/"},{"@type":"ListItem","position":2,"name":"A Classic &#8217;80s Superhero Movie Reboot Just Finished Filming"}]},{"@type":"Article","@id":"https://www.giantfreakinrobot.com/ent/toxic-avenger-filmed.html#article","isPartOf":{"@id":"https://www.giantfreakinrobot.com/ent/toxic-avenger-filmed.html#webpage"},"author":{"@id":"https://www.giantfreakinrobot.com/#/schema/person/025bd3691f75f9cb1d916d812b0fcf8b"},"headline":"A Classic &#8217;80s Superhero Movie Reboot Just Finished Filming","datePublished":"2021-08-16T16:56:53+00:00","dateModified":"2021-08-16T16:56:53+00:00","mainEntityOfPage":{"@id":"https://www.giantfreakinrobot.com/ent/toxic-avenger-filmed.html#webpage"},"wordCount":552,"publisher":{"@id":"https://www.giantfreakinrobot.com/#organization"},"image":{"@id":"https://www.giantfreakinrobot.com/ent/toxic-avenger-filmed.html#primaryimage"},"thumbnailUrl":"https://www.giantfreakinrobot.com/wp-content/uploads/2021/08/1980s-superhero-action-icons-movie.jpg","keywords":["Elijah Wood","kevin bacon","Macon Blair","Peter Dinklage","the toxic avenger","The Toxic Blair"],"articleSection":["Movies &amp; TV"],"inLanguage":"en-US"},{"@type":"Person","@id":"https://www.giantfreakinrobot.com/#/schema/person/025bd3691f75f9cb1d916d812b0fcf8b","name":"Apeksha Bagchi","image":{"@type":"ImageObject","@id":"https://www.giantfreakinrobot.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/f75522993774f755cd2c0c9c427d332f?s=96&d=mm&r=pg","contentUrl":"https://secure.gravatar.com/avatar/f75522993774f755cd2c0c9c427d332f?s=96&d=mm&r=pg","caption":"Apeksha Bagchi"},"url":"https://www.giantfreakinrobot.com/author/apekshabagchi"}]}</script>

<link rel='dns-prefetch' href='//stackpath.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//www.giantfreakinrobot.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//pagead2.googlesyndication.com' />
<link rel="alternate" type="application/rss+xml" title="GIANT FREAKIN ROBOT &raquo; Feed" href="https://www.giantfreakinrobot.com/feed" />
<link rel="alternate" type="application/rss+xml" title="GIANT FREAKIN ROBOT &raquo; Comments Feed" href="https://www.giantfreakinrobot.com/comments/feed" />
<link rel='stylesheet' id='wp-block-library-css' href='https://www.giantfreakinrobot.com/wp-includes/css/dist/block-library/style.min.css?ver=6e9206bf0172c007edc47023b8dce927' media='all' />
<style id='wp-block-library-theme-inline-css'>
#start-resizable-editor-section{display:none}.wp-block-audio figcaption{color:#555;font-size:13px;text-align:center}.is-dark-theme .wp-block-audio figcaption{color:hsla(0,0%,100%,.65)}.wp-block-code{font-family:Menlo,Consolas,monaco,monospace;color:#1e1e1e;padding:.8em 1em;border:1px solid #ddd;border-radius:4px}.wp-block-embed figcaption{color:#555;font-size:13px;text-align:center}.is-dark-theme .wp-block-embed figcaption{color:hsla(0,0%,100%,.65)}.blocks-gallery-caption{color:#555;font-size:13px;text-align:center}.is-dark-theme .blocks-gallery-caption{color:hsla(0,0%,100%,.65)}.wp-block-image figcaption{color:#555;font-size:13px;text-align:center}.is-dark-theme .wp-block-image figcaption{color:hsla(0,0%,100%,.65)}.wp-block-pullquote{border-top:4px solid;border-bottom:4px solid;margin-bottom:1.75em;color:currentColor}.wp-block-pullquote__citation,.wp-block-pullquote cite,.wp-block-pullquote footer{color:currentColor;text-transform:uppercase;font-size:.8125em;font-style:normal}.wp-block-quote{border-left:.25em solid;margin:0 0 1.75em;padding-left:1em}.wp-block-quote cite,.wp-block-quote footer{color:currentColor;font-size:.8125em;position:relative;font-style:normal}.wp-block-quote.has-text-align-right{border-left:none;border-right:.25em solid;padding-left:0;padding-right:1em}.wp-block-quote.has-text-align-center{border:none;padding-left:0}.wp-block-quote.is-large,.wp-block-quote.is-style-large{border:none}.wp-block-search .wp-block-search__label{font-weight:700}.wp-block-group.has-background{padding:1.25em 2.375em;margin-top:0;margin-bottom:0}.wp-block-separator{border:none;border-bottom:2px solid;margin-left:auto;margin-right:auto;opacity:.4}.wp-block-separator:not(.is-style-wide):not(.is-style-dots){width:100px}.wp-block-separator.has-background:not(.is-style-dots){border-bottom:none;height:1px}.wp-block-separator.has-background:not(.is-style-wide):not(.is-style-dots){height:2px}.wp-block-table thead{border-bottom:3px solid}.wp-block-table tfoot{border-top:3px solid}.wp-block-table td,.wp-block-table th{padding:.5em;border:1px solid;word-break:normal}.wp-block-table figcaption{color:#555;font-size:13px;text-align:center}.is-dark-theme .wp-block-table figcaption{color:hsla(0,0%,100%,.65)}.wp-block-video figcaption{color:#555;font-size:13px;text-align:center}.is-dark-theme .wp-block-video figcaption{color:hsla(0,0%,100%,.65)}.wp-block-template-part.has-background{padding:1.25em 2.375em;margin-top:0;margin-bottom:0}#end-resizable-editor-section{display:none}
</style>
<style id="google-fonts-css" media="all">@font-face {
  font-family: 'Karla';
  font-style: italic;
  font-weight: 400;
  font-display: swap;
  src: url(/fonts.gstatic.com/s/karla/v15/qkBKXvYC6trAT7RQNNK2EG7SIwPWMNlCV3lIb7Y.ttf) format('truetype');
}
@font-face {
  font-family: 'Karla';
  font-style: normal;
  font-weight: 400;
  font-display: swap;
  src: url(/fonts.gstatic.com/s/karla/v15/qkBIXvYC6trAT55ZBi1ueQVIjQTD-JqaE0lP.ttf) format('truetype');
}
@font-face {
  font-family: 'Karla';
  font-style: normal;
  font-weight: 700;
  font-display: swap;
  src: url(/fonts.gstatic.com/s/karla/v15/qkBIXvYC6trAT55ZBi1ueQVIjQTDH52aE0lP.ttf) format('truetype');
}
@font-face {
  font-family: 'Lato';
  font-style: italic;
  font-weight: 400;
  font-display: swap;
  src: url(/fonts.gstatic.com/s/lato/v17/S6u8w4BMUTPHjxsAXC-v.ttf) format('truetype');
}
@font-face {
  font-family: 'Lato';
  font-style: normal;
  font-weight: 300;
  font-display: swap;
  src: url(/fonts.gstatic.com/s/lato/v17/S6u9w4BMUTPHh7USSwiPHA.ttf) format('truetype');
}
@font-face {
  font-family: 'Lato';
  font-style: normal;
  font-weight: 400;
  font-display: swap;
  src: url(/fonts.gstatic.com/s/lato/v17/S6uyw4BMUTPHjx4wWw.ttf) format('truetype');
}
@font-face {
  font-family: 'Lato';
  font-style: normal;
  font-weight: 700;
  font-display: swap;
  src: url(/fonts.gstatic.com/s/lato/v17/S6u9w4BMUTPHh6UVSwiPHA.ttf) format('truetype');
}
@font-face {
  font-family: 'Lato';
  font-style: normal;
  font-weight: 900;
  font-display: swap;
  src: url(/fonts.gstatic.com/s/lato/v17/S6u9w4BMUTPHh50XSwiPHA.ttf) format('truetype');
}
@font-face {
  font-family: 'Poppins';
  font-style: normal;
  font-weight: 300;
  font-display: swap;
  src: url(/fonts.gstatic.com/s/poppins/v15/pxiByp8kv8JHgFVrLDz8Z1xlEA.ttf) format('truetype');
}
@font-face {
  font-family: 'Poppins';
  font-style: normal;
  font-weight: 400;
  font-display: swap;
  src: url(/fonts.gstatic.com/s/poppins/v15/pxiEyp8kv8JHgFVrJJfedw.ttf) format('truetype');
}
@font-face {
  font-family: 'Poppins';
  font-style: normal;
  font-weight: 600;
  font-display: swap;
  src: url(/fonts.gstatic.com/s/poppins/v15/pxiByp8kv8JHgFVrLEj6Z1xlEA.ttf) format('truetype');
}
@font-face {
  font-family: 'Poppins';
  font-style: normal;
  font-weight: 700;
  font-display: swap;
  src: url(/fonts.gstatic.com/s/poppins/v15/pxiByp8kv8JHgFVrLCz7Z1xlEA.ttf) format('truetype');
}
</style>
<link rel='stylesheet' id='fontawesome-css' href='https://www.giantfreakinrobot.com/wp-content/themes/face3-gfr/node_modules/@fortawesome/fontawesome-free/css/all.min.css?ver=1.0.59' media='all' />
<link rel='stylesheet' id='twentynineteen-style-css' href='https://www.giantfreakinrobot.com/wp-content/themes/twentynineteen/style.css?ver=1.0.59' media='all' />
<link rel='stylesheet' id='face3_gfr-main-style-css' href='https://www.giantfreakinrobot.com/wp-content/themes/face3-gfr/assets/css/main.css?ver=1.0.59' media='all' />
<link rel='stylesheet' id='twentynineteen-print-style-css' href='https://www.giantfreakinrobot.com/wp-content/themes/twentynineteen/print.css?ver=1.0.59' media='print' />
<script src='https://www.giantfreakinrobot.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script>
<script src='https://www.giantfreakinrobot.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<link rel="https://api.w.org/" href="https://www.giantfreakinrobot.com/wp-json/" /><link rel="alternate" type="application/json" href="https://www.giantfreakinrobot.com/wp-json/wp/v2/posts/270348" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.giantfreakinrobot.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.giantfreakinrobot.com/wp-includes/wlwmanifest.xml" />
<link rel='shortlink' href='https://www.giantfreakinrobot.com/?p=270348' />
<link rel="alternate" type="application/json+oembed" href="https://www.giantfreakinrobot.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.giantfreakinrobot.com%2Fent%2Ftoxic-avenger-filmed.html" />
<link rel="alternate" type="text/xml+oembed" href="https://www.giantfreakinrobot.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.giantfreakinrobot.com%2Fent%2Ftoxic-avenger-filmed.html&#038;format=xml" />
<meta property="fb:pages" content="89650649583" />
<meta name="generator" content="Site Kit by Google 1.37.0" /> <meta name="onesignal" content="wordpress-plugin" />
<script>

      window.OneSignal = window.OneSignal || [];

      OneSignal.push( function() {
        OneSignal.SERVICE_WORKER_UPDATER_PATH = "OneSignalSDKUpdaterWorker.js.php";
                      OneSignal.SERVICE_WORKER_PATH = "OneSignalSDKWorker.js.php";
                      OneSignal.SERVICE_WORKER_PARAM = { scope: "/" };
        OneSignal.setDefaultNotificationUrl("https://www.giantfreakinrobot.com");
        var oneSignal_options = {};
        window._oneSignalInitOptions = oneSignal_options;

        oneSignal_options['wordpress'] = true;
oneSignal_options['appId'] = '0da4479e-40de-41e6-8a92-544497ed15c4';
oneSignal_options['allowLocalhostAsSecureOrigin'] = true;
oneSignal_options['welcomeNotification'] = { };
oneSignal_options['welcomeNotification']['disable'] = true;
oneSignal_options['path'] = "https://www.giantfreakinrobot.com/wp-content/plugins/onesignal-free-web-push-notifications/sdk_files/";
oneSignal_options['safari_web_id'] = "web.onesignal.auto.1bb493cc-6f2b-4253-90e1-02d85a4b9e78";
oneSignal_options['persistNotification'] = false;
oneSignal_options['promptOptions'] = { };
oneSignal_options['promptOptions']['actionMessage'] = "Giant Freakin Robot will notify you when we post a story you want.";
oneSignal_options['promptOptions']['acceptButtonText'] = "CONTINUE";
oneSignal_options['promptOptions']['cancelButtonText'] = "EXIT";
oneSignal_options['promptOptions']['siteName'] = "http://www.giantfreakinrobot.com";
                OneSignal.init(window._oneSignalInitOptions);
                OneSignal.showSlidedownPrompt();      });

      function documentInitOneSignal() {
        var oneSignal_elements = document.getElementsByClassName("OneSignal-prompt");

        var oneSignalLinkClickHandler = function(event) { OneSignal.push(['registerForPushNotifications']); event.preventDefault(); };        for(var i = 0; i < oneSignal_elements.length; i++)
          oneSignal_elements[i].addEventListener('click', oneSignalLinkClickHandler, false);
      }

      if (document.readyState === 'complete') {
           documentInitOneSignal();
      }
      else {
           window.addEventListener("load", function(event){
               documentInitOneSignal();
          });
      }
    </script>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><script>(adsbygoogle = window.adsbygoogle || []).push({"google_ad_client":"ca-pub-5908537285259979","enable_page_level_ads":true,"tag_partner":"site_kit"});</script> <style id="wp-custom-css">
			.pw-pos-top.is-docked {
	margin-top: 65px !important;
}

body.single .entry .wp-block-quote {
	border-left: 5px solid #969696;
	padding-left: 20px; 
}

body.single .entry .wp-block-quote p {
	font-size: 28px !important;
	color: 343434;
	display: block;
	line-height: 30px;
	font-style: normal;
	padding-right: 20px;
}

body.single .entry .wp-block-quote cite {
	font-size: 14px;
	    color: #969696;
		}
		</style>

<link rel="preload" href="https://stackpath.bootstrapcdn.com/bootstrap/4.1.1/js/bootstrap.min.js" as="script">
<link rel="preload" href="https://www.giantfreakinrobot.com/wp-content/themes/face3-gfr/assets/js/main.min.js?ver=1.0.59" as="script">
<link rel="preload" href="https://www.giantfreakinrobot.com/wp-content/themes/twentynineteen/js/priority-menu.js?ver=20181214" as="script">
<link rel="preload" href="https://www.giantfreakinrobot.com/wp-content/themes/twentynineteen/js/touch-keyboard-navigation.js?ver=20181231" as="script">
<link rel="preload" href="/wp-includes/js/wp-embed.min.js" as="script">
<link rel="preload" href="https://cdn.onesignal.com/sdks/OneSignalSDK.js#asyncload" as="script">
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-145028702-1"></script>
<script>
    window.dataLayer = window.dataLayer || [ ];
    function gtag () {
        dataLayer.push( arguments );
    }
    gtag( 'js', new Date() );
    gtag( 'config', 'UA-145028702-1' );
</script> 
<meta name="p:domain_verify" content="fc00e490a42be9ae12e4d56349187cc2" />

<meta property="fb:pages" content="89650649583" />
<meta name="google-site-verification" content="wMkK-uYT4GgevZbCg_eeUwlTpkH4YO8pyqsAEBNm3DY" />

<script type="text/javascript">
        var tyche = { mode: 'tyche', config: '//config.playwire.com/1024236/v2/websites/72570/banner.json' }
    </script>
<script id="tyche" src="//cdn.intergient.com/pageos/pageos.js" type="text/javascript"></script>

<style type="text/css">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</style>

</head>
<body class="post-template-default single single-post postid-270348 single-format-standard wp-custom-logo wp-embed-responsive singular image-filters-enabled">
<form class="form-inline my-2 my-md-0 d-none">
<input class="form-control" type="text" placeholder="Search" aria-label="Search">
</form>
<div class="ad_container afs_ads" style="width: 730px; height: 90px; position: absolute; left: -11111px; top: -111px; pointer-events: none;"></div>
<div class="b-anterior">
<div class="dtads-slot dtads-slot-atn dtads-desktop dtads-is-rendered" id="dtads-atn-avyydchwhd5" data-google-query-id="CLOWn6vBlOUCFc0XhgodNekBAQ">
<div id="google_ads_iframe_/5611/dt.dgt.www_0__container__" style="border: 0pt none; margin: auto; text-align: center; width: 930px; height: 90px;max-width: 100%;"></div>
</div>
<div class="dtads-slot dtads-slot-atn-tablet dtads-tablet"></div>
<div class="dtads-slot dtads-out-of-page dtads-desktop dtads-tablet dtads-mobile" id="dtads-out-of-page-407ml99e97h" data-google-query-id="CM2F77vAlOUCFeiGWgUdxSIBjQ"><div id="google_ads_iframe_/5611/dt.dgt.www_1__container__" style="border: 0pt none; margin: auto; text-align: center; width: 1px; height: 1px;"></div></div>
</div>
<header>
<meta name="p:domain_verify" content="fc00e490a42be9ae12e4d56349187cc2" />
<nav class="navbar navbar-expand-lg navbar-dark bg-dark-gray" role="navigation">
<div class="container">
<a class="navbar-brand" href="https://www.giantfreakinrobot.com"><img alt="Giant Freakin Robot" height="56" width="188" src="/wp-content/themes/face3-gfr/assets/images/GFR-logo-dev-b6030d-4.1.png" /></a>
<button class="navbar-toggler second-button" type="button" data-toggle="collapse" data-target="#navbarsExample07" aria-controls="navbarsExample07" aria-expanded="false" aria-label="Toggle navigation">
<div class="animated-icon2">
<span></span><span></span><span></span><span></span>
</div>
</button>
<div class="collapse navbar-collapse" id="navbarsExample07">
<div id="bs-example-navbar-collapse-1" class="navbar-nav m-md-auto"><ul id="menu-top-menu" class="nav navbar-nav m-md-auto"><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-122507" class="d-block d-lg-none no-both search menu-item menu-item-type-custom menu-item-object-custom menu-item-122507 nav-item"><a href="#" class="nav-link"><i class="fas fa-search"></i></a></li>
<li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-122363" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children dropdown active menu-item-122363 nav-item"><a title="Movies and TV News" href="https://www.giantfreakinrobot.com/category/ent" aria-haspopup="true" aria-expanded="false" class="nav-link" id="menu-item-dropdown-122363">Movies &#038; TV</a>
<ul class="dropdown-menu" aria-labelledby="menu-item-dropdown-122363" role="menu">
<li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-256319" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-256319 nav-item"><a title="On Netflix" href="https://www.giantfreakinrobot.com/topic/netflix" class="dropdown-item">On Netflix</a></li>
<li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-252032" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-252032 nav-item"><a title="New Movies &#038; TV Coming Soon" href="https://www.giantfreakinrobot.com/topic/coming-soon" class="dropdown-item">Coming Soon</a></li>
<li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-256322" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-256322 nav-item"><a title="Confirmed Scoops" href="https://www.giantfreakinrobot.com/topic/confirmed" class="dropdown-item">Confirmed Exclusives</a></li>
<li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-258090" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-258090 nav-item"><a title="reviews" href="https://www.giantfreakinrobot.com/topic/reviews" class="dropdown-item">Reviews</a></li>
</ul>
</li>
<li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-140178" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-140178 nav-item"><a title="Culture News" href="https://www.giantfreakinrobot.com/category/cltr" class="nav-link">Culture</a></li>
<li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-221352" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children dropdown menu-item-221352 nav-item"><a title="Video Games News" href="https://www.giantfreakinrobot.com/category/games" aria-haspopup="true" aria-expanded="false" class="nav-link" id="menu-item-dropdown-221352">Games</a>
<ul class="dropdown-menu" aria-labelledby="menu-item-dropdown-221352" role="menu">
<li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-256334" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-256334 nav-item"><a title="Nintendo News" href="https://www.giantfreakinrobot.com/topic/nintendo" class="dropdown-item">Nintendo</a></li>
<li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-256331" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-256331 nav-item"><a title="Playstation News" href="https://www.giantfreakinrobot.com/topic/playstation" class="dropdown-item">Playstation</a></li>
<li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-256328" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-256328 nav-item"><a title="XBox Games" href="https://www.giantfreakinrobot.com/topic/xbox" class="dropdown-item">XBox</a></li>
</ul>
</li>
<li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-221358" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children dropdown menu-item-221358 nav-item"><a title="Science and Technology news" href="https://www.giantfreakinrobot.com/category/sci,tech" aria-haspopup="true" aria-expanded="false" class="nav-link" id="menu-item-dropdown-221358">Science &#038; Tech</a>
<ul class="dropdown-menu" aria-labelledby="menu-item-dropdown-221358" role="menu">
<li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-256337" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-256337 nav-item"><a title="Science news" href="https://www.giantfreakinrobot.com/category/sci" class="dropdown-item">Science News</a></li>
<li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-256340" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-256340 nav-item"><a title="Tech News" href="https://www.giantfreakinrobot.com/category/tech" class="dropdown-item">Tech News</a></li>
<li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-256325" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-256325 nav-item"><a title="snakes" href="https://www.giantfreakinrobot.com/topic/snakes" class="dropdown-item">Snakes Gone Wild</a></li>
</ul>
</li>
</ul></div>
<div id="bs-example-navbar-collapse-2" class="menu-top-social-container"><ul id="menu-top-social" class="nav navbar-nav m-auto"><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-122215" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-122215 nav-item"><a title="GFR Facebook" href="https://www.facebook.com/giantfreakinrobot/" class="nav-link"><i class="fab fa-facebook-f"></i></a></li>
<li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-122217" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-122217 nav-item"><a title="GFR Twitter" href="https://twitter.com/GFRobot" class="nav-link"><i class="fab fa-twitter"></i></a></li>
<li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-122214" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-122214 nav-item"><a href="https://flipboard.com/@gfrobot" class="nav-link"><i class="fab fa-flipboard"></i></a></li>
<li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-122216" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-122216 nav-item"><a title="Follow Us On Google news" href="https://news.google.com/publications/CAAqBwgKMOKklgswxcmtAw" class="nav-link"><i class="fab fa-google"></i></a></li>
<li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-122218" class="d-none d-lg-block menu-item menu-item-type-custom menu-item-object-custom menu-item-122218 nav-item"><a href="#" class="nav-link"><i class="fas fa-search"></i></a></li>
</ul></div> </div>
</div>
</nav>
<div class="search-bar bg-dark-gray fade-in">
<form class="search" action="https://www.giantfreakinrobot.com/" method="get">
<input type='text' name='s' autocomplete="off">
<input type='submit' value="Search">
</form>
</div>
<meta name="pocket-site-verification" content="5665f2fa77c896be0baea4ea51492e" />
</header>
<main role="main">
<div class="container">

<div style="margin-top:-30px">

</div>

<div class="pw-leaderboard-atf-container">
<div class="pw-ph-leaderboard" data-pw-desk="leaderboard_atf" data-pw-mobi="leaderboard_atf">
</div>
</div> <div style="height:20px">

</div>

<div class="row">
<div class="col-lg-8">

<article id="post-270348" class="row no-gutters post-270348 post type-post status-publish format-standard has-post-thumbnail hentry category-ent tag-elijah-wood tag-kevin-bacon tag-macon-blair tag-peter-dinklage tag-the-toxic-avenger tag-the-toxic-blair entry">

<div class="col-12 text-md-left">
<div class="breadcrumbs" typeof="BreadcrumbList" vocab="https://schema.org/">
<span property="itemListElement" typeof="ListItem"><a property="item" typeof="WebPage" title="Go to GIANT FREAKIN ROBOT." href="https://www.giantfreakinrobot.com" class="home"><span property="name">GIANT FREAKIN ROBOT</span></a><meta property="position" content="1"></span> &gt; <span property="itemListElement" typeof="ListItem"><a property="item" typeof="WebPage" title="Go to the Movies &amp; TV category archives." href="https://www.giantfreakinrobot.com/category/ent" class="taxonomy category" aria-current="page"><span property="name">Movies &amp; TV</span></a><meta property="position" content="2"></span></div> <h1 class="entry-title"><a href="https://www.giantfreakinrobot.com/ent/toxic-avenger-filmed.html" rel="bookmark">A Classic &#8217;80s Superhero Movie Reboot Just Finished Filming</a></h1>
<p class="font-weight-normal about-author">
By <a href="https://www.giantfreakinrobot.com/author/apekshabagchi" title="Apeksha Bagchi">Apeksha Bagchi</a>
| <span>6 seconds ago</span> </p>
<p class="font-weight-normal">
<figure class="wp-block-image size-large"><img loading="lazy" width="900" height="600" src="https://www.giantfreakinrobot.com/wp-content/uploads/2021/08/the-toxic-avenger-poster-feature-900x600.jpg" alt="the toxic avenger" class="wp-image-270363" srcset="https://www.giantfreakinrobot.com/wp-content/uploads/2021/08/the-toxic-avenger-poster-feature-900x600.jpg 900w, https://www.giantfreakinrobot.com/wp-content/uploads/2021/08/the-toxic-avenger-poster-feature-578x385.jpg 578w, https://www.giantfreakinrobot.com/wp-content/uploads/2021/08/the-toxic-avenger-poster-feature-768x512.jpg 768w, https://www.giantfreakinrobot.com/wp-content/uploads/2021/08/the-toxic-avenger-poster-feature.jpg 1200w" sizes="(max-width: 900px) 100vw, 900px" /></figure>
<p>At a time when the coronavirus pandemic is rearing its head again and film productions are getting shuttered one after another with a fresh wave of positive cases amongst its crew and cast, the news of a production actually managing to complete its shooting is certainly a cause of celebration. This is especially if the topic of our conversation is the recently concluded filming of the highly awaited <em>The Toxic Avenger. </em></p><div class='code-block code-block-1' style='margin: 8px 0; clear: both;'>
<div class="pw-in-article-ad-container">
<div class="pw-in-article">
<div data-pw-desk="med_rect_btf" data-pw-mobi="med_rect_btf">
</div>
</div>
</div></div>
<p>A reboot of the original 1984 film of the same name, <em>The Toxic Avenger </em>is directed by Macon Blair and was filmed in Bulgaria. Recently, Blair took to <a href="https://twitter.com/AlsoBlair/status/1426275206285385731?s=20">Twitter</a> to announce that they have finished filming the superhero comedy horror film. Elijah Wood, one of the actors in the film, also <a href="https://twitter.com/elijahwood/status/1426336665828724736?s=20">responded</a> to the tweet by sharing that shooting the film was a fun experience.</p>
<figure class="wp-block-embed is-type-rich is-provider-twitter wp-block-embed-twitter"><div class="wp-block-embed__wrapper">
<blockquote class="twitter-tweet" data-width="550" data-dnt="true"><p lang="en" dir="ltr">That’s a wrap. Blagodarya, Bulgaria. <a href="https://twitter.com/hashtag/TheToxicAvenger?src=hash&amp;ref_src=twsrc%5Etfw">#TheToxicAvenger</a> <a href="https://t.co/0RUW10C8Ib">pic.twitter.com/0RUW10C8Ib</a></p>&mdash; MaconBlairAlso (@AlsoBlair) <a href="https://twitter.com/AlsoBlair/status/1426275206285385731?ref_src=twsrc%5Etfw">August 13, 2021</a></blockquote><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
</div></figure>
<p><em>The Toxic Avenger, </em>due to release in 2022, was first announced in 2013 and will be the fifth film in the franchise, although it will be a “contemporary reimagining” of the original blockbuster. For now, all that is known about the film is that its core storyline will follow the first film i.e., we will see a “struggling everyman” get turned into a mutant freak when he is pushed into a vat of toxic waste. While he was a nobody before the incident, he becomes a hero when he decides to go up against bigger powers, dabbling in corruption to quench their ever-increasing greed, to save his son, friends, and community. As reported by <a href="https://deadline.com/2020/11/peter-dinklage-legendarys-toxic-avenger-reboot-1234635150/">Deadline</a> previously, <em>The Toxic Avenger</em> will also include environmental themes and will be twisting the superhero genre somewhat like the <em>Deadpool </em>films.&nbsp;</p>
<p>Initially, when the film was announced, Arnold Schwarzenegger was going to join the cast of the film. But at the time he also had <em>Terminator Genisys </em>in his hands and opted to drop <em>The Toxic Avenger. </em>For a few years, the development of the film and the process of picking its cast was paused until 2020 when <a href="https://www.giantfreakinrobot.com/ent/peter-dinklage-popular-netflix.html">Peter Dinklage</a> became the first actor to join the cast followed by Jacob Tremblay, Taylour Paige, Kevin Bacon, Julia Davis, and <a href="https://www.giantfreakinrobot.com/ent/elijah-wood-video-game.html">Elijah Wood</a>. While it is yet to be disclosed what roles the carefully selected cast will be playing, it has been <a href="https://www.hollywoodreporter.com/movies/movie-news/kevin-bacon-tapped-for-villain-role-in-legendarys-toxic-avenger-exclusive-1234966815/">reported</a> that Bacon has been brought on board to play the villain in the film. The film is produced by Lloyd Kaufman and Michael Herz, who were also the directors and producers of the 1984 film. </p>
<div class='code-block code-block-7' style='margin: 8px 0; clear: both;'>
<div class="pw-in-article-relevant-container">
<div class="pw-relevant-article">
<div></div>
</div>
</div></div>
<p>As stated above, no explicit details about the upcoming <em>The Toxic Avenger </em>are known, but Kaufman has <a href="https://www.dreadcentral.com/news/368131/epic-interview-lloyd-kaufman-gives-update-on-toxic-avenger-reboot-talks-46-years-of-troma/">praised</a> the choice of Blair as the writer/director of the reboot and claimed that its script is better than the original. Kaufman has no doubts that the film will be terrific as Blair is well-versed in the unique sense of humor of <em>The Toxic Avenger </em>franchise and already loves all the films under it. To his credit, even though Blair has only directed one film in the past i.e., <em>I Don’t Feel Like At Home In This World Anymore, </em>it ended up <a href="https://en.wikipedia.org/wiki/I_Don%27t_Feel_at_Home_in_This_World_Anymore#:~:text=The%20film%20had%20its%20world,for%20the%20U.S.%20Dramatic%20competition.">winning</a> the Grand Jury Prize at 2017’s Sundance Film Festival. Only time will tell if Blair successfully brought his unique vision to this film as well or not. Fingers crossed!</p>

</p>


<div class="pw-med-rect-btf-container">
<div class="pw-ph-med-rect" data-pw-desk="med_rect_btf" data-pw-mobi="med_rect_btf">
</div>
</div> 
<div class='yarpp yarpp-related yarpp-related-website yarpp-template-yarpp-template-example'>
<div class="row no-gutters related-article">
<div class="col-12 text-left">
<h3>related articles</h3>
</div>
<div class="col-12 items">
<div class="row">
<a href="https://www.giantfreakinrobot.com/ent/elijah-wood-cancel-culture.html" class="col-6 col-md item">

<img src="https://www.giantfreakinrobot.com/wp-content/uploads/2021/07/elijah-wood-movie-200x200.jpeg" class="img-fluid w-100" />
 <p>Elijah Wood&#8217;s New Movie Attracts Cancel Culture</p>

</a>
<a href="https://www.giantfreakinrobot.com/ent/elijah-wood-video-game.html" class="col-6 col-md item">

<img src="https://www.giantfreakinrobot.com/wp-content/uploads/2021/07/elijah-wood-movie-200x200.jpeg" class="img-fluid w-100" />
<p>Elijah Wood Wants To Adapt A Violent Video Game</p>

</a>
<a href="https://www.giantfreakinrobot.com/ent/cobra-kai-hbo.html" class="col-6 col-md item">

<img src="https://www.giantfreakinrobot.com/wp-content/uploads/2021/06/cobra-kai-200x200.jpg" class="img-fluid w-100" />
<p>Cobra Kai Was Inspired By A Controversial And Violent HBO Show</p>

</a>
<a href="https://www.giantfreakinrobot.com/ent/dc-super-villain-series.html" class="col-6 col-md item">

<img src="https://www.giantfreakinrobot.com/wp-content/uploads/2021/06/dc-supervillains-200x200.jpg" class="img-fluid w-100" />
<p>The Ultimate DC Super Villain Getting His Own Series</p>

</a>
</div>
</div>
</div>
</div>
<div class="prev_cmn_ad_tag_bottom_article">
</div>
</div>

</article>
 </div>
<div id="sidebar" class="d-md-block col-lg-4 col-xs-12">
<div class="prev_cmn_ad_tag_top_sidebar"></div>
<h2 class="trending ">Trending</h2>
<div class="posts-trending ">

<div id="post-270348" class="row no-gutters post-270348 post type-post status-publish format-standard has-post-thumbnail hentry category-ent tag-elijah-wood tag-kevin-bacon tag-macon-blair tag-peter-dinklage tag-the-toxic-avenger tag-the-toxic-blair entry">

<div class="col-12">
<a href="https://www.giantfreakinrobot.com/ent/toxic-avenger-filmed.html">

<img width="385" height="200" src="https://www.giantfreakinrobot.com/wp-content/uploads/2021/08/1980s-superhero-action-icons-movie-385x200.jpg" class="img-fluid w-100 wp-post-image" alt="1980s toxic avenger" loading="lazy" srcset="https://www.giantfreakinrobot.com/wp-content/uploads/2021/08/1980s-superhero-action-icons-movie-385x200.jpg 385w, https://www.giantfreakinrobot.com/wp-content/uploads/2021/08/1980s-superhero-action-icons-movie-900x468.jpg 900w" sizes="(max-width: 385px) 100vw, 385px" /> <h4 class="entry-title">A Classic &#8217;80s Superhero Movie Reboot Just Finished Filming</h4> <p class="author"><span>6 seconds ago</span></p>
</a>
</div>

</div>


<div id="post-270312" class="row no-gutters post-270312 post type-post status-publish format-standard has-post-thumbnail hentry category-ent tag-chris-evans entry">

<div class="col-12">
<a href="https://www.giantfreakinrobot.com/ent/chris-evans-series.html">

<img width="385" height="200" src="https://www.giantfreakinrobot.com/wp-content/uploads/2021/08/chris-evans-knives-out-385x200.png" class="img-fluid w-100 wp-post-image" alt="Chris Evans" loading="lazy" srcset="https://www.giantfreakinrobot.com/wp-content/uploads/2021/08/chris-evans-knives-out-385x200.png 385w, https://www.giantfreakinrobot.com/wp-content/uploads/2021/08/chris-evans-knives-out-900x468.png 900w" sizes="(max-width: 385px) 100vw, 385px" /> <h4 class="entry-title">Chris Evans Is Making A Series About The Middle East</h4> <p class="author"><span>1 hour ago</span></p>
</a>
</div>

</div>


<div id="post-270321" class="row no-gutters post-270321 post type-post status-publish format-standard has-post-thumbnail hentry category-ent tag-dc tag-dc-cinematic-universe tag-dc-comics tag-sylvester-stallone tag-the-suicide-squad entry">

<div class="col-12">
<a href="https://www.giantfreakinrobot.com/ent/sylvester-stallone-career-milestone.html">

<img width="385" height="200" src="https://www.giantfreakinrobot.com/wp-content/uploads/2021/08/sylvester-stallone-rocky-385x200.jpg" class="img-fluid w-100 wp-post-image" alt="sylvester stallone rocky" loading="lazy" srcset="https://www.giantfreakinrobot.com/wp-content/uploads/2021/08/sylvester-stallone-rocky-385x200.jpg 385w, https://www.giantfreakinrobot.com/wp-content/uploads/2021/08/sylvester-stallone-rocky-900x468.jpg 900w" sizes="(max-width: 385px) 100vw, 385px" /> <h4 class="entry-title">Sylvester Stallone Just Celebrated A Huge Career Milestone</h4> <p class="author"><span>1 hour ago</span></p>
</a>
</div>

</div>


<div id="post-270315" class="row no-gutters post-270315 post type-post status-publish format-standard has-post-thumbnail hentry category-ent tag-john-cena tag-peacemaker tag-superman entry">

<div class="col-12">
<a href="https://www.giantfreakinrobot.com/ent/john-cena-peacemaker-superman.html">

<img width="385" height="200" src="https://www.giantfreakinrobot.com/wp-content/uploads/2021/05/john-cena-peacemaker-385x200.jpg" class="img-fluid w-100 wp-post-image" alt="john cena peacemaker" loading="lazy" srcset="https://www.giantfreakinrobot.com/wp-content/uploads/2021/05/john-cena-peacemaker-385x200.jpg 385w, https://www.giantfreakinrobot.com/wp-content/uploads/2021/05/john-cena-peacemaker-900x468.jpg 900w" sizes="(max-width: 385px) 100vw, 385px" /> <h4 class="entry-title">John Cena&#8217;s Peacemaker Calls Out Superman&#8217;s Patriotism</h4> <p class="author"><span>2 hours ago</span></p>
</a>
</div>

</div>

</div>
<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<div style="margin-top:-50px;">

</div>

<div class="pw-med-rect-btf-container">
<div class="pw-ph-med-rect" data-pw-desk="med_rect_btf" data-pw-mobi="med_rect_btf">
</div>
</div> <div style="height:30px">

</div>

<h2 class="top-stories">Top Stories</h2>
<div class="posts-top-stories">

<div id="post-269376" class="row no-gutters post-270261 post type-post status-publish format-standard has-post-thumbnail hentry category-ent tag-mission-impossible-2 tag-mission-impossible-7-2 tag-paramount-pictures tag-paramount-2 tag-tom-cruise entry">

<div class="col-12">
<a href="https://www.giantfreakinrobot.com/ent/robert-downey-jr-replaced.html">

<img width="385" height="200" src="https://www.giantfreakinrobot.com/wp-content/uploads/2021/07/iron-man-3-robert-downey-jr-suit-385x200.jpg" class="img-fluid wp-post-image" alt="robert downey jr" loading="lazy" srcset="https://www.giantfreakinrobot.com/wp-content/uploads/2021/07/iron-man-3-robert-downey-jr-suit-385x200.jpg 385w, https://www.giantfreakinrobot.com/wp-content/uploads/2021/07/iron-man-3-robert-downey-jr-suit-900x468.jpg 900w" sizes="(max-width: 385px) 100vw, 385px" /> <h4 class="entry-title">Robert Downey Jr. Being Replaced As Iron Man?</h4>
<p class="author"><span>3 days ago</span></p>
</a>
</div>

 </div>


<div id="post-269448" class="row no-gutters post-270261 post type-post status-publish format-standard has-post-thumbnail hentry category-ent tag-mission-impossible-2 tag-mission-impossible-7-2 tag-paramount-pictures tag-paramount-2 tag-tom-cruise entry">

<div class="col-12">
<a href="https://www.giantfreakinrobot.com/ent/shang-chi-boycott.html">

<img width="385" height="200" src="https://www.giantfreakinrobot.com/wp-content/uploads/2021/04/shang-chi-1-385x200.jpeg" class="img-fluid wp-post-image" alt="shang-chi simu liu" loading="lazy" srcset="https://www.giantfreakinrobot.com/wp-content/uploads/2021/04/shang-chi-1-385x200.jpeg 385w, https://www.giantfreakinrobot.com/wp-content/uploads/2021/04/shang-chi-1-578x301.jpeg 578w, https://www.giantfreakinrobot.com/wp-content/uploads/2021/04/shang-chi-1-900x468.jpeg 900w, https://www.giantfreakinrobot.com/wp-content/uploads/2021/04/shang-chi-1-768x401.jpeg 768w, https://www.giantfreakinrobot.com/wp-content/uploads/2021/04/shang-chi-1.jpeg 1110w" sizes="(max-width: 385px) 100vw, 385px" /> <h4 class="entry-title">Shang-Chi Faces Boycott From Marvel Fans</h4>
<p class="author"><span>3 days ago</span></p>
</a>
</div>

</div>


<div id="post-269793" class="row no-gutters post-270261 post type-post status-publish format-standard has-post-thumbnail hentry category-ent tag-mission-impossible-2 tag-mission-impossible-7-2 tag-paramount-pictures tag-paramount-2 tag-tom-cruise entry">

<div class="col-12">
<a href="https://www.giantfreakinrobot.com/ent/sopranos-prequel-series.html">

<img width="385" height="200" src="https://www.giantfreakinrobot.com/wp-content/uploads/2020/09/sopranos-prequel-many-saints-of-newark-feature-385x200.jpg" class="img-fluid wp-post-image" alt="sopranos prequel many saints of newark feature" loading="lazy" srcset="https://www.giantfreakinrobot.com/wp-content/uploads/2020/09/sopranos-prequel-many-saints-of-newark-feature-385x200.jpg 385w, https://www.giantfreakinrobot.com/wp-content/uploads/2020/09/sopranos-prequel-many-saints-of-newark-feature-900x468.jpg 900w" sizes="(max-width: 385px) 100vw, 385px" /> <h4 class="entry-title">Sopranos Prequel Movie Getting a Series</h4>
<p class="author"><span>2 days ago</span></p>
</a>
</div>

</div>


<div id="post-269457" class="row no-gutters post-270261 post type-post status-publish format-standard has-post-thumbnail hentry category-ent tag-mission-impossible-2 tag-mission-impossible-7-2 tag-paramount-pictures tag-paramount-2 tag-tom-cruise entry">

<div class="col-12">
<a href="https://www.giantfreakinrobot.com/ent/kristen-stewart-streaming-underwater.html">

<img width="385" height="200" src="https://www.giantfreakinrobot.com/wp-content/uploads/2021/08/kristen-stewart-385x200.jpg" class="img-fluid wp-post-image" alt="kristen stewart" loading="lazy" srcset="https://www.giantfreakinrobot.com/wp-content/uploads/2021/08/kristen-stewart-385x200.jpg 385w, https://www.giantfreakinrobot.com/wp-content/uploads/2021/08/kristen-stewart-900x468.jpg 900w" sizes="(max-width: 385px) 100vw, 385px" /> <h4 class="entry-title">An Underrated Kristen Stewart Movie Is Finding Fans On Streaming</h4>
<p class="author"><span>3 days ago</span></p>
</a>
</div>

</div>


<div id="post-269580" class="row no-gutters post-270261 post type-post status-publish format-standard has-post-thumbnail hentry category-ent tag-mission-impossible-2 tag-mission-impossible-7-2 tag-paramount-pictures tag-paramount-2 tag-tom-cruise entry">

<div class="col-12">
<a href="https://www.giantfreakinrobot.com/ent/margot-robbie-harley-quinn-forced-out.html">

<img width="385" height="200" src="https://www.giantfreakinrobot.com/wp-content/uploads/2021/08/margot-robbie-harley-quinn-1-385x200.jpg" class="img-fluid wp-post-image" alt="margot robbie harley quinn" loading="lazy" srcset="https://www.giantfreakinrobot.com/wp-content/uploads/2021/08/margot-robbie-harley-quinn-1-385x200.jpg 385w, https://www.giantfreakinrobot.com/wp-content/uploads/2021/08/margot-robbie-harley-quinn-1-900x468.jpg 900w" sizes="(max-width: 385px) 100vw, 385px" /> <h4 class="entry-title">Margot Robbie Being Forced Out As Harley Quinn?</h4>
<p class="author"><span>3 days ago</span></p>
</a>
</div>

</div>

</div>

<div style="margin-top:-50px;">

</div>

<div class="pw-med-rect-btf-container">
<div class="pw-ph-med-rect" data-pw-desk="med_rect_btf" data-pw-mobi="med_rect_btf">
</div>
</div> <div style="height:30px">

</div>

<div class="sidebar-widget">
<h2 class="must-read">Must Read</h2>
<div class="posts-must-read">

<div id="post-265944" class="row no-gutters post-270315 post type-post status-publish format-standard has-post-thumbnail hentry category-ent tag-john-cena tag-peacemaker tag-superman entry">

<div class="col-12">
<a href="https://www.giantfreakinrobot.com/ent/the-best-star-trek-starships.html">

<img width="385" height="200" src="https://www.giantfreakinrobot.com/wp-content/uploads/2021/08/enterprise-refit-385x200.jpeg" class="img-fluid wp-post-image" alt="" loading="lazy" srcset="https://www.giantfreakinrobot.com/wp-content/uploads/2021/08/enterprise-refit-385x200.jpeg 385w, https://www.giantfreakinrobot.com/wp-content/uploads/2021/08/enterprise-refit-900x468.jpeg 900w" sizes="(max-width: 385px) 100vw, 385px" /> <h4 class="entry-title">The Best Star Trek Starships</h4>
</a>
</div>

</div>


<div id="post-122980" class="row no-gutters post-270315 post type-post status-publish format-standard has-post-thumbnail hentry category-ent tag-john-cena tag-peacemaker tag-superman entry">

<div class="col-12">
<a href="https://www.giantfreakinrobot.com/ent/the-matrix-4-all.html">

<img width="385" height="200" src="https://www.giantfreakinrobot.com/wp-content/uploads/2020/08/matrixrope-385x200.jpg" class="img-fluid wp-post-image" alt="" loading="lazy" srcset="https://www.giantfreakinrobot.com/wp-content/uploads/2020/08/matrixrope-385x200.jpg 385w, https://www.giantfreakinrobot.com/wp-content/uploads/2020/08/matrixrope-900x468.jpg 900w" sizes="(max-width: 385px) 100vw, 385px" /> <h4 class="entry-title">The Matrix 4: All About The Keanu Reeves Starring Sequel</h4>
</a>
</div>

</div>


<div id="post-149110" class="row no-gutters post-270315 post type-post status-publish format-standard has-post-thumbnail hentry category-ent tag-john-cena tag-peacemaker tag-superman entry">

<div class="col-12">
<a href="https://www.giantfreakinrobot.com/cltr/tom-welling.html">

<img width="385" height="200" src="https://www.giantfreakinrobot.com/wp-content/uploads/2020/08/superman-385x200.jpg" class="img-fluid wp-post-image" alt="" loading="lazy" srcset="https://www.giantfreakinrobot.com/wp-content/uploads/2020/08/superman-385x200.jpg 385w, https://www.giantfreakinrobot.com/wp-content/uploads/2020/08/superman-900x468.jpg 900w" sizes="(max-width: 385px) 100vw, 385px" /> <h4 class="entry-title">Tom Welling: Why He Faded Away After Smallville</h4>
</a>
</div>

</div>


<div id="post-141100" class="row no-gutters post-270315 post type-post status-publish format-standard has-post-thumbnail hentry category-ent tag-john-cena tag-peacemaker tag-superman entry">

<div class="col-12">
<a href="https://www.giantfreakinrobot.com/ent/eva-mendes.html">

<img width="385" height="200" src="https://www.giantfreakinrobot.com/wp-content/uploads/2020/06/evamendes-385x200.jpg" class="img-fluid wp-post-image" alt="eva mendes" loading="lazy" srcset="https://www.giantfreakinrobot.com/wp-content/uploads/2020/06/evamendes-385x200.jpg 385w, https://www.giantfreakinrobot.com/wp-content/uploads/2020/06/evamendes-900x468.jpg 900w" sizes="(max-width: 385px) 100vw, 385px" /> <h4 class="entry-title">Eva Mendes: Why She Stopped Acting And Why Its Ryan Gosling&#8217;s Fault</h4>
</a>
</div>

</div>

</div>
</div>
</div> </div>

<div style="height:20px">

</div>

<div class="pw-leaderboard-btf-container">
<div class="pw-ph-leaderboard" data-pw-desk="leaderboard_btf" data-pw-mobi="leaderboard_btf">
</div>
</div> <div style="height:20px">

</div>

<div class='code-block code-block-16' style='margin: 8px 0; clear: both;'>
<div id="zergnet-widget-82164"></div>
<script language="javascript" type="text/javascript">
	(function() {
		var zergnet = document.createElement('script');
		zergnet.type = 'text/javascript'; zergnet.async = true;
		zergnet.src = (document.location.protocol == "https:" ? "https:" : "http:") + '//www.zergnet.com/zerg.js?id=82164';
		var znscr = document.getElementsByTagName('script')[0];
		znscr.parentNode.insertBefore(zergnet, znscr);
	})();
</script></div>
</div>
</main>
<footer class="text-muted">
<div class="container">
<p class="float-right">
<a href="#" class="back-to-top">
<svg aria-hidden="true" focusable="false" data-prefix="fal" data-icon="chevron-up" role="img" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 448 512" class="svg-inline--fa fa-chevron-up fa-w-14 fa-2x"><path fill="currentColor" d="M4.465 366.475l7.07 7.071c4.686 4.686 12.284 4.686 16.971 0L224 178.053l195.494 195.493c4.686 4.686 12.284 4.686 16.971 0l7.07-7.071c4.686-4.686 4.686-12.284 0-16.97l-211.05-211.051c-4.686-4.686-12.284-4.686-16.971 0L4.465 349.505c-4.687 4.686-4.687 12.284 0 16.97z" class=""></path></svg>
</a>
</p>
</div>
</footer>
<footer class="no-gutters footer">
<div class="container">
<div class="row">
<div class="col-12 col-md-6 col-lg-3 column-1">
<a class="navbar-brand" href="https://www.giantfreakinrobot.com"><img loading="lazy" width="270" height="114" src="https://www.giantfreakinrobot.com/wp-content/themes/face3-gfr/assets/images/gfr-footer-logo.png" /></a>
<p>Giant Freakin Robot stomps into the future of everything that matters. We offer unique information that impacts everything you care most about in the world, all in one place.</p>
<h3>Affiliate Disclosure</h3>
<p>Giant Freakin Robot may get a commission from retail offers.</p>
<h3>Add Us on Social</h3>
<ul class="social">
<li><a href="https://www.facebook.com/giantfreakinrobot/" target="_blank"><i class="fab fa-facebook-f"></i></a></li>
<li><a href="https://twitter.com/GFRobot" target="_blank"><i class="fab fa-twitter"></i></a></li>
<li><a href="https://www.instagram.com/gfrobo/" target="_blank"><i class="fab fa-instagram"></i></a></li>
<li><a href="https://www.linkedin.com/company/gfrobot/" target="_blank"><i class="fab fa-linkedin"></i></a></li>
<li><a href="https://news.google.com/publications/CAAqBwgKMOKklgswxcmtAw" target="_blank"><i class="fab fa-google"></i></a></li>
<li><a href="https://www.youtube.com/c/GiantFreakinRobot" target="_blank"><i class="fab fa-youtube"></i></a></li>
<li><a href="https://flipboard.com/@GFRobot" target="_blank"><i class="fab fa-flipboard"></i></a></li>
<li><a href="/feed" target="_blank"><i class="fas fa-rss"></i></a></li>
</ul>
</div>
<div class="col-12 col-md-6 col-lg-3">
<h3>Who We Are</h3>
<div id="bs-example-navbar-collapse-2" class="menu-footer-1-container"><ul id="menu-footer-1" class="nav navbar-nav m-auto"><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-83887" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-83887 nav-item"><a title="About Us" href="https://www.giantfreakinrobot.com/about-us" class="nav-link">About Us</a></li>
<li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-122222" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-122222 nav-item"><a title="Privacy Policy" href="https://www.giantfreakinrobot.com/privacy-policy" class="nav-link">Privacy Policy</a></li>
<li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-122219" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-122219 nav-item"><a title="Contact Us" href="https://www.giantfreakinrobot.com/contact" class="nav-link">Contact Us</a></li>
<li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-122221" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-122221 nav-item"><a title="Careers" href="https://www.giantfreakinrobot.com/jobs" class="nav-link">Careers</a></li>
</ul></div> </div>
<div class="col-12 col-md-6 col-lg-3">
<h3>Must Read</h3>
<div id="bs-example-navbar-collapse-2" class="menu-footer-tags-container"><ul id="menu-footer-tags" class="nav navbar-nav m-auto"><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-153316" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-153316 nav-item"><a title="Star Wars News" href="https://www.giantfreakinrobot.com/topic/star-wars" class="nav-link">Star Wars News</a></li>
<li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-153317" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-153317 nav-item"><a title="Star Trek News" href="https://www.giantfreakinrobot.com/topic/star-trek" class="nav-link">Star Trek News</a></li>
<li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-222834" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-222834 nav-item"><a title="Superhero News" href="https://www.giantfreakinrobot.com/topic/marvel,dc-comics" class="nav-link">Superhero News</a></li>
<li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-258081" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-258081 nav-item"><a title="Dwayne Johnson News" href="https://www.giantfreakinrobot.com/topic/dwayne-johnson" class="nav-link">Dwayne Johnson News</a></li>
<li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-258096" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-258096 nav-item"><a title="henry cavill news" href="https://www.giantfreakinrobot.com/topic/henry-cavill" class="nav-link">Henry Cavill News</a></li>
<li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-258087" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-258087 nav-item"><a title="disney news" href="https://www.giantfreakinrobot.com/topic/disney" class="nav-link">Breaking Disney News</a></li>
</ul></div> </div>
</div>
</div>
</footer>
<link rel='stylesheet' id='yarppRelatedCss-css' href='https://www.giantfreakinrobot.com/wp-content/plugins/yet-another-related-posts-plugin/style/related.css?ver=5.27.0' media='all' />
<script src='https://stackpath.bootstrapcdn.com/bootstrap/4.1.1/js/bootstrap.min.js' id='bootstrap-js'></script>
<script src='https://www.giantfreakinrobot.com/wp-content/themes/face3-gfr/assets/js/main.min.js?ver=1.0.59' id='face3_gfr-main-script-js'></script>
<script src='https://www.giantfreakinrobot.com/wp-content/themes/twentynineteen/js/priority-menu.js?ver=20181214' id='twentynineteen-priority-menu-js'></script>
<script src='https://www.giantfreakinrobot.com/wp-content/themes/twentynineteen/js/touch-keyboard-navigation.js?ver=20181231' id='twentynineteen-touch-navigation-js'></script>
<script src='https://www.giantfreakinrobot.com/wp-includes/js/wp-embed.min.js?ver=6e9206bf0172c007edc47023b8dce927' id='wp-embed-js'></script>
<script src='https://cdn.onesignal.com/sdks/OneSignalSDK.js?ver=6e9206bf0172c007edc47023b8dce927' async='async' id='remote_sdk-js'></script>
<script>
	/(trident|msie)/i.test(navigator.userAgent)&&document.getElementById&&window.addEventListener&&window.addEventListener("hashchange",function(){var t,e=location.hash.substring(1);/^[A-z0-9_-]+$/.test(e)&&(t=document.getElementById(e))&&(/^(?:a|select|input|button|textarea)$/i.test(t.tagName)||(t.tabIndex=-1),t.focus())},!1);
	</script>


<script type="text/javascript">
    var _qevents = _qevents || [ ];

    ( function () {
        var elem = document.createElement( 'script' );
        elem.src = ( document.location.protocol == "https:" ? "https://secure" : "http://edge" ) + ".quantserve.com/quant.js";
        elem.async = true;
        elem.type = "text/javascript";
        var scpt = document.getElementsByTagName( 'script' )[0];
        scpt.parentNode.insertBefore( elem, scpt );
    } )();

    _qevents.push( {
        qacct: "p-889gzjdmeT5iw"
    } );
</script>
<noscript>
<div style="display:none;">
    <img src="//pixel.quantserve.com/pixel/p-889gzjdmeT5iw.gif" border="0" height="1" width="1" alt="Quantcast"/>
</div>
</noscript>
<script type="text/javascript">
    amzn_assoc_ad_type = "link_enhancement_widget";
    amzn_assoc_tracking_id = "gfrobot05-20";
    amzn_assoc_linkid = "633d40f62c281bfc721b203d2fa5c49a";
    amzn_assoc_placement = "";
    amzn_assoc_marketplace = "amazon";
    amzn_assoc_region = "US";
</script>
<script src="//ws-na.amazon-adsystem.com/widgets/q?ServiceVersion=20070822&Operation=GetScript&ID=OneJS&WS=1&MarketPlace=US"></script>

</body>
</html>